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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence Tools»Clear ERC Markers»Entire design 
directs you to pull down the Tools menu, select the Clear ERC Markers 
item, and select Entire design from the resulting dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.
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1
Introduction to NI Circuit Design 
Suite

Some of the described features may not be available in your edition of 
Circuit Design Suite. Refer to the NI Circuit Design Suite Release Notes for 
a description of the features available in your edition. 

NI Circuit Design Suite Product Line 
National Instruments Circuit Design Suite is a suite of EDA (Electronics 
Design Automation) tools that assists you in carrying out the major steps in 
the circuit design flow. 

Multisim is the schematic capture and simulation program designed for 
schematic entry, simulation, and feeding to downstage steps, such as PCB 
layout. It also includes mixed analog/digital simulation capability, and 
microcontroller co-simulation. 

Ultiboard is used to design printed circuit boards, perform certain basic 
mechanical CAD operations, and prepare them for manufacturing. It also 
provides automated parts placement and layout. 

The Tutorials 
This book contains the following step-by-step tutorials: 

• Multisim Tutorial—Introduces you to Multisim and its many 
functions. 

• Ultiboard Tutorial—Shows you how to place the components and 
traces for the circuit described in the Multisim Tutorial chapter. You 
will also learn how to autoplace parts and then autoroute them. 

• Multisim MCU Tutorial—Leads you through the process of simulating 
and debugging a circuit that contains a microcontroller. 

For more detailed information on the features discussed in these chapters, 
refer to the Multisim Help or the Ultiboard Help. 
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2
Multisim Tutorial

This chapter contains a tutorial that introduces you to Multisim and its 
many functions. 

Some of the described features may not be available in your edition of 
Circuit Design Suite. Refer to the NI Circuit Design Suite Release Notes for 
a description of the features available in your edition. 

Introduction to the Multisim Interface 
Multisim is the schematic capture and simulation application of National 
Instruments Circuit Design Suite, a suite of EDA (Electronics Design 
Automation) tools that assists you in carrying out the major steps in the 
circuit design flow. Multisim is designed for schematic entry, simulation, 
and feeding to downstage steps, such as PCB layout. 
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Multisim’s user interface consists of the following basic elements:
 

The Menu Bar is where you find commands for all functions. 

The Design Toolbox is where you navigate through the different types of 
files in a project (schematics, PCBs, reports), view a schematic’s hierarchy 
and show or hide different layers. 

The Component toolbar contains buttons that you use to select 
components from the Multisim databases for placement in your schematic. 

The Standard toolbar contains buttons for commonly-performed functions 
such as Save, Print, Cut, and Paste. 

1 Menu Bar
2 Design Toolbox
3 Component Toolbar
4 Standard Toolbar

5 View Toolbar
6 Simulation Toolbar
7 Main Toolbar

8 In Use List
9 Instruments Toolbar
10 Scroll Left/Right

11 Circuit Window
12 Spreadsheet View
13 Active Tab
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The View toolbar contains buttons for modifying the way the screen is 
displayed.

The Simulation toolbar contains buttons for starting, stopping, and other 
simulation functions. 

The Main toolbar contains buttons for common Multisim functions.

The In Use List contains a list of all components used in the design. 

The Instruments toolbar contains buttons for each instrument. 

The Circuit Window (or workspace) is where you build your circuit 
designs. 

The Spreadsheet View allows fast advanced viewing and editing of 
parameters including component details such as footprints, RefDes, 
attributes and design constraints. You can change parameters for some 
or all components in one step and perform a number of other functions. 

Overview 
This tutorial leads you through the circuit design flow, from schematic 
capture, through simulation and analysis. After following the steps outlined 
on the following pages, you will have designed a circuit that samples a 
small analog signal, amplifies it and then counts the occurrences of the 
signal on a simple digital counter. 

Helpful tips are indicated by the presence of an icon in the left column, 
as in: 

Tip You can access the online help at any time by pressing <F1> on your keyboard, or by 
clicking on the Help button in a dialog box. 

When you get to the wiring section of this tutorial, you can carry on with 
the circuit you created in the component placement section. 

Alternatively, you can open Getting Started 1.ms11, found at 
...\samples\Getting Started\. This file has all of the components 
properly placed. 

When you arrive at the simulation section, you can carry on with the circuit 
you wired, or open Getting Started 2.ms11, which has all of the 
components properly wired. 
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Schematic Capture 
In this section, you will place and wire the components in the circuit shown 
below.

 

Opening and Saving the File 
Complete the following step to launch Multisim:

1. Select Start»All Programs»National Instruments»Circuit Design 
Suite 11.0»Multisim 11.0. A blank file opens on the workspace called 
Design1. 

Complete the following steps to save the file with a new name: 

1. Select File»Save As to display a standard Windows Save dialog.

2. Navigate to the location where you wish the file to reside, enter 
MyGettingStarted as the filename, and click the Save button.
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Tip To guard against accidental loss of data, set up a timed auto-backup of the file in the 
Save tab of the Global Preferences dialog box. 

Complete the following step to open an existing file:

1. Select File»Open, navigate to the location where the file resides, 
highlight the file, and click on the Open button. 

Tip To view files from earlier versions of Multisim, select the desired version in the Files 
of Type drop-down in the Open dialog. 

Placing the Components 
Complete the following steps to start placing components:

1. Open MyGettingStarted.ms11 as described above. 

2. Select Place»Component to display the Select a Component dialog 
box, navigate to the 7-segment LED display as shown below and click 
OK. The component appears as a “ghost” on the cursor. 

Tip Once you have selected the desired Group and Family, start typing the component’s 
name in the browser’s Component field. As you type, the string appears in the Searching 
field at the bottom of the browser. In the example below, type 
seven_seg_decimal_com_a_blue. Matches are displayed as you type.
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3. Move the cursor to the bottom-right of the workspace and left-click to 
place the component. Notice that the Reference Designator for this 
component is “U1”. 
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4. Place the remaining components in the Digital Counter area as shown 
below. 

 

Note When placing resistors, inductors, or capacitors (RLC components), the Select a 
Component dialog box has slightly different fields than for other components. When 
placing these components, you can choose any combination of: the component’s value (for 
example, the resistance value); type (for example, carbon film); tolerance; footprint and 
manufacturer. If you are placing a component that will be ultimately exported to PCB 
layout, and become part of a Bill of Materials, you must be careful that the combination 
of values that you select in the Select a Component dialog box are available in a 
real-world, purchaseable component. 

Tip When placing RLC components, type the value of the device that you want to place 
in the field at the top of the Component list. The value does not need to appear in the list 
to be placed on the schematic. 

Tip While placing the 200  resistor, rotate it to a vertical orientation by pressing 
<Ctrl-R> on your keyboard. 

Tip Reference Designators (for example, U1, U2) are assigned in the order the 
components are placed. If you place components in a different order than in the original 
circuit, the numbering will differ. This will not affect the operation of the circuit in any way. 
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5. Place the components in the Counter Control section. After placement, 
right-click on each of the SPDT switches and select Flip Horizontal.

 

Tip The SPDT switches are in the Basic group, Switch family. 

Tip When a component is on the workspace and you want to place the same component 
again, highlight it and select Edit»Copy, then Edit»Paste. You can also select it from the 
In Use List and click to place it on the workspace. 

6. Place the components in the Analog Amplifier section as shown below, 
rotating as needed.

 

After you place the AC voltage signal source, double-click on it. 
Change the Voltage (Pk) to 0.2 V and click OK to close the dialog. 
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7. Place the components in the Bypass Capacitors section as shown 
below.

 

8. Place the header and associated components as shown below.
 

Tip J3 is in the Basic Group; Connectors Family.

Tip Once you have wired a circuit, you can drop two-pinned components like resistors 
directly onto a wire. The connection is automatically made by Multisim. 

Wiring the Circuit 
All components have pins that you use to wire them to other components 
or instruments. As soon as your cursor is over a pin, Multisim knows you 
want to wire and the pointer changes to a crosshair. 

Tip You can wire the circuit that you placed on the workspace or you can use 
Getting Started 1.ms11 from the Getting Started folder (found inside the 
samples folder). 
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Complete the following steps to wire the circuit: 

1. Click on a pin on a component to start the connection (your pointer 
turns into a crosshair) and move the mouse. A wire appears, attached 
to your cursor. 

2. Click on a pin on the second component to finish the connection. 
Multisim automatically places the wire, which conveniently snaps to 
an appropriate configuration, as shown below. This feature saves a 
great deal of time when wiring large circuits.

 

Tip You can also control the flow of the wire by clicking on points as you move the mouse. 
Each click “fixes” the wire to that point. 
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3. Finish wiring the Digital Counter section as shown below. 
 

Tip Use Bus Vector Connect to wire multi-pinned devices like U3 and R4 together in a 
bus. Refer to the Multisim Help for details. 

Tip Virtual Wiring—To avoid clutter, you can use virtual connections between the 
Counter Control and Digital Counter sections. When two nets have the same net name, they 
are virtually connected. 
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4. Finish wiring the circuit as shown below.
 

Simulation 
Simulating your circuits with Multisim catches errors early in the design 
flow, saving time and money. 

Virtual Instrumentation 
In this section, you will simulate the circuit with the virtual oscilloscope. 

Tip You can also use Getting Started 2.ms11 from the Getting Started folder 
(found inside the samples folder). 

1. J1, J2 and R2 are interactive components. 

Set up the interactive keys for J1, J2 and R2 by double-clicking on each 
and selecting the Value tab. In the Key field, enter “E” for J1, “L” for 
J2, and “A” for R2. 

2. Press <E> on the keyboard to enable the counter, or just click on the 
widened switch arm that appears when you hover the cursor over J1. 

3. Select Simulate»Instruments»Oscilloscope to place the oscilloscope 
on the workspace. Wire the instrument as shown in step 5. 
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Tip To easily differentiate between traces on the oscilloscope, right-click on the wire 
connected to the scope’s “B” input and select Color Segment from the context menu that 
displays. Select a color that differs from the wire connected to the “A” input, for example 
blue. (Changing wire color or performing any other editing function cannot be done while 
simulation is running).

4. Double-click on the scope’s icon to show the instrument face. Select 
Simulate»Run. The output of the opamp appears on the scope.  

5. Adjust the Timebase to 2 ms/Div and Channel A’s Scale to 
500 mV/Div. You will see the following displayed on the scope.

 

As the circuit simulates, the 7-segment display counts up and the LED 
flashes at the end of each count cycle. 

6. Press <E> on your keyboard while the simulation is running to enable 
or disable the counter. Enable is Active Low. 

Press <L> to load zeros into the counter. Load is Active Low. 

Press <Shift-A> to observe the effect of decreasing the potentiometer’s 
setting. Repeat, pressing A to increase. 

Tip Instead of pressing the above-mentioned keys, you can directly manipulate the 
interactive components on the schematic with your mouse. 
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Analysis 
In this section, you will use AC Analysis to verify the frequency response 
of the amplifier. 

Complete the following steps to perform an AC Analysis at the output of 
the opamp: 

1. Double-click on the wire that is attached to pin 6 of the opamp, and 
change the net name to analog_out in the Net dialog box. 

2. Select Simulate»Analyses»AC Analysis and click on the Output tab.
 

3. Highlight V(analog_out) in the left column and click Add. 
V(analog_out) moves to the right column. This will display the 
voltage at node V(analog_out).
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4. Click Simulate. The results of the analysis appear in the Grapher.

The Grapher 
The Grapher is a multi-purpose display tool that lets you view, adjust, save 
and export graphs and charts. It is used to display the results of all Multisim 
analyses in graphs and charts and a graph of traces for some instruments 
(for example the results of the oscilloscope). 
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Complete the following steps to view results of a simulation on the 
Grapher: 

1. Run the simulation as described earlier. 

2. Select View»Grapher. 

The Postprocessor 
Use the Postprocessor to manipulate the output from analyses performed 
on a circuit and plot the results on a graph or chart. Types of mathematical 
operations that can be performed on analysis results include arithmetic, 
trigonometric, exponential, logarithmic, complex, vector and logic. 

Reports 
You can generate a number of reports in Multisim: Bill of Materials 
(BOM), Component Detail Report, Netlist Report, Schematic 
Statistics, Spare Gates and the Cross Reference Report. This section 
uses the BOM as an example for the tutorial circuit. 
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Bill of Materials 
A bill of materials lists the components used in your design and therefore 
provides a summary of the components needed to manufacture the circuit 
board. Information provided includes: 

• quantity of each component needed.

• description, including the type of component (example: resistor) and 
value (example: 5.1 kohm). 

• Reference Designator of each component. 

• package or footprint of each component. 

Complete the following step to create a BOM (bill of materials) for your 
circuit: 

1. Select Reports»Bill of Materials. 

The report appears, looking similar to this: 
 

To print the Bill of Materials, click the Print button. A standard Windows 
print dialog box appears, allowing you to choose the printer, number of 
copies, and so on.  

To save the Bill of Materials to a file, click the Save button. A standard 
Windows file save dialog box appears, where you specify the path and file 
name.  
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Because the Bill of Materials is primarily intended to assist in procurement 
and manufacturing, it includes only “real” components—it excludes 
components that are not real or available for purchase, such as sources or 
virtual components. Components without assigned footprints do not appear 
in the Bill of Materials. 

To see a list of components in your circuit that are not “real” components, 
click the Virtual button. A separate window appears, showing these 
components only.  

Detailed information on this and other reports can be found in the 
Multisim Help. 
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3
Ultiboard Tutorial

The tutorial in this chapter places the parts and traces for the circuit 
described in the Multisim Tutorial chapter. 

Tip For instructions on exporting a design from Multisim to Ultiboard, refer to the 
Multisim Help and the Ultiboard Help. 

Some of the described features may not be available in your edition of 
Ultiboard. Refer to the NI Circuit Design Suite Release Notes for a 
description of the features available in your edition. 

Introduction to the Ultiboard Interface 
Ultiboard is the PCB layout application of National Instruments Circuit 
Design Suite, a suite of EDA (Electronics Design Automation) tools that 
assists you in carrying out the major steps in the circuit design flow. 

Ultiboard is used to lay out and route printed circuit boards, perform certain 
basic mechanical CAD operations, and prepare them for manufacturing. It 
also provides automated parts placement and layout. 

Ultiboard’s user interface is made up of several elements. 
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The Menu Bar is where you find commands for all functions. 

The Standard toolbar contains buttons for commonly-performed functions 
such as Save, Print, Cut, and Paste. 

As you add more parts and traces to a board, it can become difficult to select 
only those which you want to use. The Select toolbar contains buttons used 
to control selections. 

The Draw Settings toolbar is where you select the layer, thickness and unit 
of measure of a line or object that is being drawn. It also contains buttons 
for functions that control the appearance of lines and shapes drawn on a 
layer. 

1 Menu Bar
2 Standard Toolbar
3 Select Toolbar
4 Draw Settings Toolbar

5 View Toolbar
6 Main Toolbar
7 Autoroute Toolbar

8 Status Bar
9 Workspace
10 Spreadsheet View

11 Design Toolbox
12 3D Preview
13 Birds Eye View
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The View toolbar contains buttons for modifying the way the screen is 
displayed.

The Main toolbar contains buttons for common board design functions.

The Autoroute toolbar contains autorouting and part placement functions. 

The Status Bar displays useful and important information. 

The Workspace is where you build your design. 

The Spreadsheet View allows fast advanced viewing and editing of 
parameters including part details such as shapes, Reference Designators, 
attributes and design constraints. 

The Design Toolbox lets you show, hide, or dim elements of your design.

The 3D Preview shows you a three-dimensional preview of the board. 

The Birds Eye View shows you the design at a glance and lets you easily 
navigate around the workspace. 

Opening the Tutorial 
Complete the following steps to open the tutorial file: 

1. Select Start»All Programs»National Instruments»Circuit Design 
Suite 11.0»Ultiboard 11.0 to launch Ultiboard.

2. Select File»Open Samples and double-click on the Getting 
Started folder to open it. 
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3. Select Getting Started.ewprj and click Open. The project file is 
loaded into Ultiboard. 

4. To select a design from the project (for example, GS1), either click on 
its tab, or click on its name in the Projects tab of the Design Toolbox. 

Creating a Board Outline 
There is already a board outline, however, you can create one that is a more 
suitable size for the parts in this design in one of the following ways:

• Draw a board outline using the drawing tools. 

• Import a DXF file.

• Use the Board Wizard.
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Complete the following steps to experiment with the Board Wizard:

1. Double-click on Board Outline in the Layers tab to make it the active 
layer.

2. Click on the existing board outline in the GS1 design and press 
<Delete> on the keyboard. 

3. Choose Tools»Board Wizard. 
 

4. Enable the Change the layer technology option to make the other 
options available. 

5. Choose Multi-layers constructed with double-sided boards and 
single layer stack-ups, and click Next. 
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6. The next dialog box is where you define the Lamination settings for 
the board. (For this tutorial you will not change settings). 

 

7. Click Next. 

In the Board Wizard - Shape of Board dialog box:

• make sure the Reference Point is set to Bottom-left for 
Alignment.

• make sure the Rectangular option is selected.

• set the Width to 3000 and the Height to 2000 (a more suitable size 
for the parts in this design).

• set the Clearance to 5.00000. This is the distance from the edge 
of the board that is to be kept free of any other elements.

8. Click Finish. The board outline is placed on your design.

Note For complete details on the Board Wizard, refer to the Ultiboard Help. 
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Complete the following steps to move the board outline:

1. Double-click on Board Outline in the Layers tab.

2. Click anywhere on the board outline in the workspace and drag the 
board to a location just below the row of parts.

Complete the following steps to change the reference point:

1. Select Design»Set Reference Point. The reference point is attached to 
your cursor.

2. Move the cursor the the lower-left corner of the board outline and click 
to place it.
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Placing Parts 
You can place parts on your GS1 design file in several different ways: 

• select one or more parts from outside the board outline and drag them 
into place. 

• use the Parts tab in the Spreadsheet View to locate parts and place 
them. 

• select parts from the database. 

Tip Use the Place»Unplace Parts command to quickly remove all non-locked parts from 
the PCB and experiment with a different placement technique. 

Dragging Parts from Outside the Board Outline 
By default, parts are placed outside the board outline when you open a 
netlist from Multisim or another schematic capture program. 

Before you begin, double-click the Copper Top layer in the Design 
Toolbox to make it the active layer. 

Complete the following steps to drag U1 from outside the board outline: 

1. Find U1 in the collection of parts outside the board outline. To make 
this easier, zoom in (press <F8>) until you can see U1. 

Tip You can also search for a part with the Edit»Find command. While this command 
works much like a Find function in other applications, it also allows you to search for a part 
by name, number, shape, value, or by all variables. Refer to the Ultiboard Help for details. 
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2. Click on U1 (the 7-segment display) and drag it to the location shown 
in the figure below. 

 

U1 remains selected. This is an important point for Ultiboard that 
holds throughout the application—you need to explicitly end any 
particular action. In this case, simply clicking somewhere else 
de-selects the part. Right-clicking also ends the current action. 

3. Go to the Parts tab in the Spreadsheet View and scroll to U1. You will 
notice that the green light beside the part is slightly brighter—this 
indicates that the part has been placed. 

Dragging Parts from the Parts Tab 
Complete the following steps to drag parts from the Parts tab: 

1. In the Parts tab, scroll down until you see J3. 
 

1 Force Vector 2 Ratsnest
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2. Click on J3 and drag it from the Parts tab onto the workspace. J3 is 
attached to your mouse pointer. 

3. Drop J3 on the left edge of the board, roughly in the middle. As before, 
in the Parts tab J3’s green light is slightly brighter, indicating that the 
part has been placed. 

Placing the Tutorial Parts 
Using any method or combination of methods, make your layout look like 
the illustration below. You can also simply open the next design file in the 
project, GS2, which has already been set up this way. 

Your design should look like this: 
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Placing Parts from the Database 
In addition to placing parts imported as part of your design file, you can 
place parts directly from the database. The following uses this method to 
place the mounting holes. 

Complete the following steps to place parts from the database:

1. Choose Place»From database. The Get a Part From the Database 
dialog box opens.  

2. In the Database panel, expand the Through Hole Technology Parts 
category and navigate to the Holes category. The parts appear in the 
Available parts panel. 

3. In the Available parts panel, select the Hole35 part. The part displays 
in the Preview panel. 

 

4. Click OK. The Get a Part From the Database dialog box disappears, 
and you are prompted to enter the RefDes and Value. 

5. Enter the hole’s reference designator (H1) and value (HOLE) and 
click OK. 

6. Move the pointer over the board. The part is attached to the pointer.
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7. When the hole is in position in the top-left corner, click to drop it on 
the board. 

8. The Enter Reference Designation for Part dialog box reappears, 
with the reference designator automatically incremented to H2. 

9. Enter the value (HOLE) and click OK to place the next mounting hole 
in the top right corner, and repeat to place H3 in the bottom right 
corner, and H4 in the bottom left corner. 

10. Click Cancel to stop, and click Cancel again to close the Get a Part 
From the Database dialog box. 

 

Moving Parts 
You can use the same methods for moving parts as you do for placing them. 
To select a part already on the board, simply click on it. To specify the 
X/Y coordinates to which the selected part is to move, press the <*> key on 
the numeric keypad. Alternatively, in the Parts tab, select a placed part 
(indicated by a bright green light beside it) and drag it to a new location. 
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Tip The part’s label is a separate element from its shape. When selecting a part on the 
board, be sure to select the whole part, not just the label. Try using the Selection Filters to 
assist with this. Refer to the Ultiboard Help for more information. 

Tip Once a part is selected, you can also move it around on the board by pressing the 
arrow keys on your keyboard. 

You can also select a group of parts and move them together. To do this, you 
can do one of the following: 

• hold down the <Shift> key and click on more than one part.

• drag a box around several parts. 

All the selected parts will move together when you drag the cursor.

Tip These are temporary groups—once you select another part, the group connection is 
lost. To make a group that remains until you remove it, you can use the Group Editor. For 
details, refer to the Ultiboard Help. 

Another option for moving parts is to use the Edit»Align commands to 
align the edges of selected parts or to space them relative to each other. 

Use the Edit»Align commands to align the mounting holes you just placed: 

1. Select H1 and hold down the Shift key to select H2. 

2. Choose Edit»Align»Align Top. If H2 was not originally placed 
exactly in line with H1, you will see it move. 

3. Click on an empty space on the board, then select H2 and H3. 

4. Choose Edit»Align»Align Right. 

5. Continue in this manner to align the bottoms of H3 and H4, and the left 
sides of H1 and H4. 

Placing Traces 
You have the following options for placing traces: 

• manual trace. 

• follow-me trace. 

• connection machine trace. 

A manual trace is placed exactly as you specify, even running through a 
component or trace if that is the path you set out. A follow-me trace 
automatically draws a legal trace between the pins you select with your 
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mouse movements—you can move from pin to pin, leaving a legal trace. A 
connection machine trace automatically joins two pins by the most efficient 
route, though you have the option of changing it. 

As you place a trace, and before you click to fix it in place, you can always 
remove a segment by backing up over it. Each time you click while placing 
a manual trace, or each time a follow-me trace or connection machine trace 
changes direction, a separate segment of that trace is created. When 
performing operations on traces, be sure to select either the appropriate 
segment or, if you wish, the whole trace. 

Placing a Manual Trace 
You can continue with the design you have been working on, or open GS3. 
Be sure you are on the Copper Top layer before beginning—Copper Top 
should be highlighted in red in the Layers tab of the Design Toolbox. 

Tip If necessary, press <F7> to show the whole design. 

Complete the following steps to place a trace manually: 

1. Choose Place»Line. 

Tip The Line command is used to create a line on any layer. The results differ depending 
on the layer selected. For example, if the selected layer is silkscreen, you will create a line 
on the silkscreen layer of the PCB. If the selected layer is a copper layer, then the “line” is 
actually a trace. 
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2. Locate J3, toward the left-hand part of the board. Find the start pin 
shown below: 

 

Tip You can turn off or dim the Force Vectors to see the nets more clearly. Do this using 
the Force Vectors checkbox in the Layers tab of the Design Toolbox. Refer to the 
Ultiboard Help for more information about Force Vectors. 

Tip If you have trouble locating the part, use the Find function of the Parts tab. Select the 
part in the Parts tab, then click the Find and select the part button. The part is shown in 
the workspace. If necessary, zoom in further using <F8>. 

3. Click on the pin specified in the above step. Ultiboard highlights all the 
pins that are part of the same net as the pin you clicked on with an X. 
(The color of the highlighting can be changed in the Colors tab of the 
Global Preferences dialog box). This is how you know where to 
connect to pins to match the connectivity from your schematic. 

1 Part J3 2 Start Pin
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4. Move the cursor in any direction. A green line (the trace) is attached to 
the selected pin. Each time you click you anchor the trace segment, as 
shown in the figure below (2). 

5. Click on the destination pin. 
 

6. Right-click to stop placing traces. 

7. Click the Select button on the Main toolbar to exit line-placing mode.  

1  Pins in the Same Net  

1 Trace
2 Click to anchor trace

3 Destination Pin
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Placing a Follow-me Trace 
Complete the following steps to place a follow-me trace: 

1. Choose Place»Follow-me.  

2. Click on the top pin of J3. 

3. Click on the second pin from the bottom in the left column of U4. 

4. Ultiboard draws the connection for you. 

Tip You do not need to click exactly on a pin—you can also start by clicking on a ratsnest 
line. 

Placing a Connection Machine Trace 
Complete the following steps to place a Connection Machine trace:

1. Choose Place»Connection Machine.  
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2. Click on the segment of the ratsnest indicated below. 
 

3. Move your cursor—Ultiboard suggests various trace placement 
options routed around obstacles. 

1 Click Ratsnest  
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4. When you see the route you want, click to fix the trace. You don’t have 
to click on the ratsnest or the destination pin. 

 

5. Right-click to end trace placement. 

Auto Part Placement 
As well as placing parts as described earlier in this chapter, you can use 
Ultiboard’s advanced automatic part placement functionality. 

Tip Before autoplacing parts, pre-place and lock any parts that you do not wish to be 
moved during the autoplacement process. (The mounting holes, and U1, J1, J2, J3, and 
LED 1 in GS5 have been pre-placed and locked). For details on locking parts, refer to the 
Ultiboard Help. 

1 Trace Segments Appear Between Pins  
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Complete the following steps to autoplace the parts in Getting 
Started.ewprj: 

1. Open the GS5 design in Ultiboard. 

2. Select Autoroute»Start Autoplacement. The parts are placed on the 
circuit board.

 

Autorouting Traces 
You can place traces in Ultiboard using the methods described earlier in 
this chapter, or automatically route the traces as described below. 

Complete the following steps to autoroute the traces in Getting 
Started.ewprj: 

1. Open the GS3 design in Ultiboard. 

2. Select Autoroute»Start/Resume Autorouter. The workspace 
switches to Autorouter Mode and trace autorouting begins. 

As autorouting proceeds, you will see traces being placed on the board. 
When autorouting is complete, Autorouter Mode closes and you are 
returned to the workspace.

3. Optionally, select Autoroute»Start Optimization to optimize the 
placement of the traces. 
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The autorouter can be stopped at any time and you can make manual 
changes as desired. When you restart the autorouter, it will continue with 
the changes you made. Remember to lock any traces that you have placed 
manually and do not wish to be moved by the autorouter. 

Tip Use the Routing Options dialog box to modify autoplacement and autorouting 
options. Refer to the Ultiboard Help for details. 

Preparing for Manufacturing/Assembly 
Ultiboard can produce many different output formats to support your 
production and manufacturing needs. This section explains the functions 
performed to output your board for production and documentation 
purposes. 

Cleaning up the Board 
Before sending the board for manufacturing, you should clean up any open 
trace ends (trace segments that do not have any terminating connections in 
the design) and unused vias that have been left on the board. 

To delete open trace ends, make sure the GS4 design is open and choose 
Edit»Copper Delete»Open Trace Ends. This deletes all open trace ends 
in the design. 
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To delete any unused vias, make sure the design is open and choose 
Design»Remove Unused Vias to delete all vias that do not have any trace 
segments or copper areas connected to them. 

Adding Comments 
Comments can be used to show engineering change orders, to facilitate 
collaborative work among team members, or to allow background 
information to be attached to a design. 

You can “pin” a comment to the workspace, or directly to a part. When a 
part with an attached comment is moved, the comment also moves. 

For details, refer to the Ultiboard Help. 

Exporting a File 
An exported file contains complete information describing how a finished 
board is to be manufactured. Files that can be exported include Gerber 
RS-274X and RS-274D files. 

For complete details, refer to the Ultiboard Help. 

Viewing Designs in 3D 
Ultiboard lets you see what the board looks like in three dimensions at any 
time during the design. For complete details, refer to the Ultiboard Help. 

 

Tip You can use the Internal View to look between the layers of a multi-layer PCB. For 
details, refer to the Ultiboard Help. 
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4
Multisim MCU Tutorial

The tutorial in this chapter leads you through the process of simulating and 
debugging a circuit that contains a microcontroller. 

Some of the described features may not be available in your edition of 
Circuit Design Suite. Refer to the NI Circuit Design Suite Release Notes for 
a description of the features available in your edition. 

Overview 
The files used for this tutorial install with your NI Circuit Design Suite 
software at ...\samples\Getting Started. 

This tutorial uses Getting Started MCU.ms11, which accesses the 
contents of folder LCDWorkspace as required. 

The LCD Graphical Display circuit example demonstrates the use of a PIC 
microcontroller to control a graphical LCD display component in Multisim 
based on a combination of the Toshiba T6963C controller and an external 
display RAM. To control the LCD display, the microcontroller sends 
signals to the LCD through the LCD’s data and control lines. A software 
program written for the microcontroller determines the logic behind setting 
the lines on its pins to high or low to send commands and data to the LCD 
display. 
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About the Tutorial 
The data lines of LCD U2 are connected to pins RB0 – RB7 on 
microcontroller U1. The control lines of the LCD are connected to RA0 - 
RA2 on the microcontroller. The MCU U1 communicates with the LCD U2 
via these wires. Data is sent to U2 in parallel and signals on the control lines 
determine the timing and type of data being sent (that is, address or data). 

The LCD Graphical Display can operate in three modes: text mode, 
graphical mode and a combination text and graphical mode. This example 
demonstrates the controlling of the LCD Graphical Display in a 
combination text and graphical mode. The software that the MCU runs is 
contained in an MCU workspace that displays in the Design Toolbox as 
LCDWorkspace. The workspace contains one project project1 that 
consists of a single source code file main.asm.  
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Complete the following to view the file:

1. Double-click on main.asm in the Design Toolbox. A tab appears in 
the schematic capture workspace called main.asm that displays the 
assembly program. 

 

To display the line numbers, select MCU»Show Line Numbers. 

Complete the following to run this circuit: 

1. Select Simulate»Run. If you did not build your program beforehand, 
a dialog box displays stating that the configuration is out of date and 
asks if you would like to build it.  Click Yes. The results of the build 
display in the Results tab of the Spreadsheet View.  

Switch back to the design tab. The program displays the line 
“Graphical LCD T6963C for Multisim” characters in text mode; the 
LCD then switches to graphical mode and draws an inverted “V” 
dot-by-dot on top of the text. 

Once the lines are drawn, the text scrolls right and then left.  This is 
achieved by moving the start address of the text buffer of the LCD 
display.  This also demonstrates that there are two buffers in the LCD, 
one for storing graphics and another for storing text. Other features of 
the LCD such as text flashing and erasing of characters are also 
demonstrated. 

The LCD display program continues to cycle through each of these 
effects. 

To stop the simulation, select Simulate»Stop.  
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Understanding the Assembly Program 
Constants and data
Switch back to main.asm. 

To make the program easier to understand, the LCD display commands and 
temporary buffers for storing addresses and data in the MCU are predefined 
in constants at the start of the program:

 

The text to be displayed on the LCD display is stored in data tables for some 
microcontrollers, but there is no PIC assembly instruction that allows you 
to directly address a data value in the program memory space. Instead, you 
can load literal values into the W register so you can write a routine that 
returns a value in your string based on an index. The RETLW instruction 
loads a constant value into the W register and executes a RETURN in one 
instruction.  

The TXPRT routine retrieves the text data to be displayed on the LCD 
display. The character codes for the LCD display are defined in the T6963C 
controller reference manual (for example, 0x27 is the code for the letter 
“G”, 0x52 for “r”, and so on): 
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Initialization
The initialization code begins at the START label as shown in the excerpt 
below. The pins in the microcontroller are set up as output pins, and 
the values are reset. The LCD display component is initialized by the 
microcontroller and set to graphical and text mode. The home addresses for 
the internal graphical and text buffers in the LCD display component are 
set to 0x0000 and 0x2941 respectively, which determines where on the 
display the LCD starts to display the buffer data. Finally, the control signals 
are set up for the proper read/write operation on the LCD display. 
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Drawing Text and Graphics
The rest of the program sends commands to the LCD graphical display via 
the control lines through MCU pins RA0 to RA2 and data through the data 
lines: 

 

For example, the above excerpt from the main loop in the program sends 
the characters defined in the TXPRT subroutine to be displayed in text mode 
on the graphical LCD. 

The following sets the LCD to auto write mode: 

MOVLW CMD_AWRON

MOVWF CMD_BUFFER

CALL CMD

At this point, the program starts counting, and executes through the loop 
LOOP_READ_DATA2 35 times. This loop calls TXPRT to retrieve the text 
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data and load it into the W register. It then calls to the subroutine ADT, 
which calls SEND_DATA, which writes the values in the W register to port 
B, to be sent to the data lines of the LCD display.  Once the data is sent, the 
proper value on port A of the microcontroller is sent to the control pins of 
the LCD display to let it know that the data is ready to be read. The 
subroutines all return at the end to the instruction just after the call to them 
and the same thing happens until all 35 characters have been transmitted. 
The final three instructions in the excerpt turn off the auto write mode in the 
LCD display after exiting the loop: 

MOVLW CMD_AWROFF

MOVWF CMD_BUFFER

CALL CMD

The next few instructions draw the horizontal and sloped lines in graphical 
mode:

;6 draw wave once

MOVF ADDR_L, 0

BTFSC STATUS, Z

CALL DRAW_WAVE

Working with the MCU Debugging Features 
This section provides a step-by-step walkthrough of Multisim’s MCU 
debugging features. It is important to follow the steps exactly as scripted, 
otherwise, the descriptions will no longer apply. Once you understand the 
breakpoint and single stepping features you can explore the possibilities of 
advanced MCU debugging. 

Debug View Overview 
To write a program for a microcontroller either in C or assembly, you create 
source code files (.asm, .inc, .c, .h) as part of the MCU workspace, 
which can in turn be edited in the source code view. 

Complete the following to access the source code view: 

1. Double-click on the file item (for example, main.asm) shown in the 
MCU workspace hierarchy in the Design Toolbox. 

During simulation, additional debugging information displays to help you 
understand what is happening inside the MCU. For example, you can 
switch between viewing events happening in the high level source and at 
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the assembly instruction level which also displays the actual opcodes for 
each instruction that are being executed by the MCU.  

The source code view is not capable of displaying all this extra information.  
Instead, each MCU component in the circuit design has its own 
Debug View that displays debugging information. 

Complete the following to access the Debug View:

1. Select MCU»MCU PIC 16F84A U1»Build. 

Note The Debug View is available only after you have successfully built your code, so 
the preceding step is only necessary once. 

2. Select MCU»MCU PIC 16F84A U1»Debug View.

Or

Use the right-click context menu on an item in the MCU workspace of 
the Design Toolbox. 

 

Another tab opens in the schematic capture workspace called 
Debug(<reference designator of MCU>), in this case Debug(U1). 
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Use the drop-down list at the top of the Debug View to select between the 
disassembly instructions generated internally by Multisim and the listing 
file generated by the assembler or compiler (the format of the listing file is 
dependant on the tool that you choose to build your code). 

In the LCD graphical display example, the code was written in assembly 
and built by the Microchip assembly tools. The Microchip assembler 
generates a listing file (.lst) that contains all of the opcodes generated for 
each assembly instruction. The debug listing view displays information 
from this listing file. Multisim generates the disassembly format using its 
internal disassembler to disassemble the opcode instructions into assembly 
instructions.  

This format is not necessary for this example since the debug listing 
contains all of the information needed. In cases where an MCU project 
loads only the machine code (.hex) file, the disassembly view shows the 
disassembled opcode instructions so that you can see what’s happening in 
the MCU. Since no listing file for MCU projects of this type is available, 
the disassembly view is very useful. 

1  Drop-down List  
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Adding a Breakpoint 
You can add breakpoints in the source code view when simulation has 
stopped, as well as during simulation. You can add breakpoints to a 
microcontroller project in two ways. 

One way is to add them in the source code view. In this example, the 
main.asm tab in the schematic capture workspace is the only source code 
view available. 

Note If your MCU design contains more than one file, there will be a source code view 
for each of your source code files. 

You can also set a breakpoint in the Debug View window. You can set 
breakpoints in the disassembly view or the debug listing view, but for this 
example, you will only use the debug listing view.

 

Complete the following to add a breakpoint in the source code view: 

1. Open the Debug View for U1. 

2. Double-click on main.asm in the Design Toolbox. 

3. Scroll to the line just below the START label: BCF STATUS, RP0. 

4. Double-click on the first (grey) column on the left side of the 
main.asm window next to the line BCF STATUS, RP0. A red circle 
appears at that location indicating that a breakpoint has been set at 
that line. 

1  Grey Column  
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5. Select Simulate»Run. The simulation automatically pauses at the 
breakpoint that you have just set. The Debug View automatically 
displays with a yellow arrow showing where the MCU program 
execution is paused.  

Complete the following to remove the breakpoint: 

1. Double-click on the breakpoint in the Debug View or the main.asm 
source code view. 

Or

Select MCU»Remove all breakpoints to remove all breakpoints.  

Note You can add and remove breakpoints in the Debug View in the same manner as the 
source code view. 

Break and Step 
1. Select MCU»Remove all breakpoints to remove all breakpoints. 

2. Go to the circuit design view (the Getting Started MCU tab) and 
select Simulate»Run. The words “Graphical LCD T6963CC for 
Multisim” start to display on the graphical LCD component.  

3. Select Simulate»Pause.  

4. Go to the Debug View for U1 and notice that the line of code in the 
debug listing view where the MCU has stopped its execution is 
indicated by a yellow arrow in the left-most column. 
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5. Select MCU»MCU PIC16F84A U1»Memory View to view the 
current state of the memory inside the microcontroller U1. Notice that 
the value of the program counter PC in the IROM section is one higher 
than the address value of the line the yellow arrow is pointing to. In the 
example in the above figure, the address in the Debug View is 192 and 
the PC value in the Memory View is 193. 

Note If the MCU has not finished executing the current command when you pause the 
simulation, the value in the program counter will be the same as the address value. 

You can also look at the other sections of the Memory View to see the 
values inside the other parts of memory in the microcontroller. 

6. Click the Step into button in the Simulation tool bar.  

7. The current instruction is executed and the simulation pauses at the 
next instruction.

8. Select Simulate»Stop.  
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Break and Step Out 
1. Place a breakpoint in the SEND_DATA subroutine at MOVWF PORTB. 

2. Select Simulate»Run. The simulation pauses at the breakpoint.  

3. Click the Step out button in the Simulation toolbar to step out of the 
SEND_DATA subroutine.  

4. The simulation executes all of the remaining instructions in the 
SEND_DATA subroutine and pauses at the first instruction after the call 
to the SEND_DATA subroutine. 

Break and Step Into 
1. Select MCU»Remove All Breakpoints.  

2. Place a breakpoint at the call to SEND_DATA where you had just 
stepped out of just above the yellow arrow. 

3. Select Simulate»Run. The simulation pauses at breakpoint that you 
just placed.  

4. Click the Step Into button on the Simulation toolbar. The simulation 
pauses inside the SEND_DATA subroutine.  

Break and Step Over 
1. Select Simulate»Run. The simulation pauses at the same breakpoint 

that you set previously at the call to the subroutine SEND_DATA.  

2. Click the Step Over button on the Simulation toolbar. The entire 
SEND_DATA subroutine is executed and the simulation pauses at the 
instruction after the CALL SEND_DATA instruction.  

Run to Cursor 
1. Select MCU»Remove All Breakpoints.  

2. Click on a line inside the SEND_DATA subroutine since we know that 
this subroutine will be called again to send data to the LCD display.

3. Click the Run to Cursor button in the Simulation toolbar. The 
simulation runs until the MCU hits the instruction that you clicked on 
inside the SEND_DATA subroutine.  It then pauses and places the yellow 
arrow next to that line.  
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A
Technical Support and 
Professional Services

Visit the following sections of the award-winning National Instruments 
Web site at ni.com for technical support and professional services:

• Support—Technical support at ni.com/support includes the 
following resources:

– Self-Help Technical Resources—For answers and solutions, 
visit ni.com/support for software drivers and updates, a 
searchable KnowledgeBase, product manuals, step-by-step 
troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. 
Registered users also receive access to the NI Discussion Forums 
at ni.com/forums. NI Applications Engineers make sure every 
question submitted online receives an answer.

– Standard Service Program Membership—This program 
entitles members to direct access to NI Applications Engineers 
via phone and email for one-on-one technical support as well as 
exclusive access to on demand training modules via the Services 
Resource Center. NI offers complementary membership for a full 
year after purchase, after which you may renew to continue your 
benefits. 

For information about other technical support options in your 
area, visit ni.com/services, or contact your local office at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.
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If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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VORÜBERGEHENDEN FEHLERN DER ELEKTRONISCHEN SYSTEME (HARDWARE UND/ODER SOFTWARE), 
UNVORHERGESEHENEN EINSATZES ODER MISSBRAUCHS ODER FEHLERN DES ANWENDERS ODER DES 
ANWENDUNGSENTWICKLERS (ENTGEGENWIRKENDE FAKTOREN WIE DIESE WERDEN NACHSTEHEND 
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KÖRPERLICHER SCHÄDEN UND TOD), SOLLTE AUFGRUND DER GEFAHR VON SYSTEMFEHLERN NICHT LEDIGLICH AUF 
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EINER SOLCHEN ANWENDUNG.



Symbole und Darstellungen

In diesem Handbuch werden die folgenden Symbole und Darstellungen 
verwendet:

» Das Symbol » kennzeichnet die Reihenfolge, in der Menüpunkte und 
Dialogfeldoptionen anzuklicken sind. So wird zum Beispiel mit der 
Abfolge Extras»ERC-Markierungen löschen»Gesamter Entwurf 
angezeigt, dass zunächst das Menü Extras zu öffnen ist, daraus die Option 
ERC-Markierungen löschen auszuwählen ist und anschließend auf 
Gesamter Entwurf zu klicken ist.

Dieses Symbol steht für Ratschläge.

Dieses Zeichen steht für einen Hinweis auf wichtige Informationen.

fett In fettgedruckter Schrift sind Elemente dargestellt, die ausgewählt oder 
angeklickt werden müsen, wie Menüpunkte oder Optionen in 
Dialogfeldern. Parameternamen sind ebenfalls fettgedruckt.

kursiv Variablen, Hervorhebungen, Querverweise und erstmals genannte 
Fachausdrücke sind durch Kursivschrift gekennzeichnet. Ebenfalls kursiv 
sind Textstellen gedruckt, an denen Wörter bzw. Werte einzusetzen sind.

monospace In Monospace-Schrift (nicht proportionaler Schrift) sind 
Programmauszüge, Syntaxbeispiele und Zeichen, die über die Tastatur 
einzugeben sind, dargestellt. Diese Darstellungsweise wird ebenfalls für 
Laufwerke, Pfade, Verzeichnisse, Programme, Unterprogramme, 
Subroutinen, Gerätenamen, Funktionen, Operationen, Variablen sowie 
Dateinamen und -erweiterungen verwendet.
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1
Einführung in die NI Circuit 
Design Suite

Einige der beschriebenen Funktionen sind möglicherweise nicht in Ihrer 
Version der Circuit Design Suite verfügbar. Eine Beschreibung Ihrer 
Edition finden Sie in den Versionshinweisen zur NI Circuit Design Suite. 

NI Circuit Design Suite 
Die Circuit Design Suite von National Instruments ist ein EDA-Software-
paket (Electronics Design Automation), mit dessen Hilfe Ihnen die 
wichtigsten Schritte zur Planung und Erstellung von Schaltungen erleich-
tert werden. 

Multisim ist ein Programm, mit dem Sie Schaltpläne erstellen, simulieren 
und an den nächsten Arbeitsgang in der Leiterplattenfertigung, zum Bei-
spiel das Leiterplattendesign, weitergeben können. Außerdem bietet das 
Programm Funktionen zur Simulation von gemischten analog/digitalen 
Schaltungen und zur Co-Simulation von Mikrocontrollern. 

Ultiboard erzeugt gedruckte Schaltungen, führt einfache mechanische 
CAD-Operationen durch (z. B. Platzieren der Bauelemente auf den Leiter-
platten) und bereitet die Leiterplatten für die Produktion vor. Außerdem 
bietet das Programm automatisierte Funktionen für Bestückung und 
Leiterplattenentwurf. 



Kapitel 1 Einführung in die NI Circuit Design Suite

Erste Schritte mit NI Circuit Design Suite 1-2 ni.com

Einführungen 
Dieses Handbuch enthält folgende Einführungen: 

• Einführung in Multisim—Stellt Ihnen Multisim und seine Funktionen 
vor. 

• Einführung in Ultiboard—Zeigt Ihnen, wie Sie die Bauelemente und 
Leiterbahnen für die im Multisim-Kapitel beschriebenen Schaltungen 
richtig platzieren. Außerdem lernen Sie, wie Bauelemente automatisch 
eingefügt und die dazugehörigen Leiterbahnen automatisch verlegt 
werden. 

• Einführung in Multisim MCU—Führt Sie durch die Simulation und 
Fehlersuche in einer Schaltung mit Mikrocontroller. 

Weiterführende Informationen zu den in diesen Kapiteln beschriebenen 
Funktionen finden Sie in der Hilfe zu Multisim und der Hilfe zu Ultiboard. 
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Einführung in Multisim

Im vorliegenden Kapitel erhalten Sie eine kurze Einführung in Multisim 
und seine Funktionen. 

Einige der beschriebenen Funktionen sind möglicherweise nicht in Ihrer 
Version der Circuit Design Suite verfügbar. Eine Beschreibung Ihrer 
Edition finden Sie in den Versionshinweisen zur NI Circuit Design Suite. 

Multisim-Benutzeroberfläche 
Multisim ist das Programm der NI Circuit Design Suite, mit dem Schaltplä-
ne erstellt und simuliert werden. Die Circuit Design Suite von National 
Instruments ist ein Softwarepaket zur automatisierten Elektronik-Entwick-
lung, die Ihnen die wichtigsten Schritte in der Schaltungsentwicklung 
erleichtert. In Multisim können Sie einen Schaltplan erstellen, Schaltungen 
simulieren und die Daten an den nächsten Arbeitsgang (z. B. Leiterplatten-
bestückung) weitergeben. 
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Die Benutzeroberfläche von Multisim ist folgendermaßen aufgebaut:
 

Die Menüleiste enthält die Befehle für sämtliche Funktionen. 

Unter Schaltungswerkzeuge können Sie nach verschiedenen Dateien 
eines Projekts suchen (z. B. Schaltplänen, Leiterplatten-Layouts oder 
Berichten), die Schaltplanhierarchie aufrufen und die darzustellenden 
Lagen auswählen. 

Über die Schaltflächen der Symbolleiste Bauelemente können Sie Bau-
elemente auswählen, die Sie in Ihre Schaltung einfügen möchten. 

1 Menüleiste
2 Schaltungswerkzeuge
3 Symbolleiste “Bauelemente”
4 Symbolleiste “Standard”
5 Symbolleiste “Ansicht”

6 Symbolleiste “Simulation”
7 Hauptleiste
8 Liste verwendeter Bauelemente
9 Symbolleiste “Instrumente”

10 Nach links/rechts scrollen
11 Schaltungsfenster
12 Tabellenansicht
13 Aktive Registerkarte
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Die Symbolleiste Standard enthält Schaltflächen für die meistverwende-
ten Funktionen wie Speichern, Drucken, Ausschneiden oder Einfügen. 

Die Symbolleiste Ansicht enthält Schaltflächen zum Ändern der 
Bildschirmanzeige.

Die Symbolleiste Simulation enthält Schaltflächen zum Steuern von 
Simulationen. 

Die Hauptleiste enthält Schaltflächen für allgemeine 
Multisim-Funktionen.

Die Liste verwendeter Bauelemente enthält eine Liste aller in der Schal-
tung verwendeten Bauelemente. 

Die Symbolleiste Instrumente enthält Schaltflächen für jedes Instrument. 

Im Schaltungsfenster (auch als Arbeitsbereich bezeichnet) wird der 
Schaltplan dargestellt. 

Die Tabellenansicht ermöglicht die Anzeige von Parametern und Bau-
elementeinformationen wie Platzbedarfsinformationen, Referenzbezeich-
nungen, Attribute und Entwurfsregeln. Hier können Sie z. B. die Parameter 
mehrerer Bauelemente gleichzeitig ändern. 

Überblick 
Dieses Dokument beleuchtet alle Aspekte der Erstellung einer technischen 
Schaltung vom Entwurf eines Schaltplans über die Simulation der Schal-
tung bis hin zur Analyse der Ergebnisse. Nach dem Abarbeiten der 
beschriebenen Schritte erstellen Sie eine Schaltung, mit der ein analoges 
Kleinsignal erfasst und verstärkt wird und dessen Auftreten mit einem ein-
fachen digitalen Zähler ermittelt wird. 

Nützliche Tipps sind links durch ein Symbol gekennzeichnet, z. B.: 

Tipp Sie können jederzeit die Hilfe aufrufen, indem Sie auf der Tastatur <F1> drücken 
oder in einem Dialogfeld die Schaltfläche Hilfe anklicken. 

Sobald Sie den Abschnitt zum Verbinden der Bauelemente erreicht haben, 
können Sie mit der Schaltung fortfahren, die Sie im Abschnitt “Einfügen 
der Bauelemente” erstellt haben. 



Kapitel 2 Einführung in Multisim

Erste Schritte mit NI Circuit Design Suite 2-4 ni.com

Alternativ können Sie die Datei Getting Started 1.ms11 
unter ...\Dokumente und Einstellungen\All Users\
Gemeinsame Dokumente\National Instruments\Circuit 

Design Suite 11.0\samples\Getting Started\ öffnen. In dieser 
Datei sind alle Bauelemente richtig platziert. 

Wenn Sie den Abschnitt “Simulation” erreicht haben, können Sie entweder 
an der vorhandenen Schaltung weiterarbeiten oder die Datei Getting 
Started 2.ms11 verwenden, in der alle Bauelemente bereits richtig ver-
bunden sind. 

Schaltplan 
In diesem Abschnitt fügen Sie die Bauelemente für die unten abgebildete 
Schaltung ein und verbinden sie miteinander.
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Öffnen und Speichern der Datei 
Zum Starten von Multisim gehen Sie wie folgt vor:

1. Wählen Sie Start»Alle Programme»National Instruments»Circuit 
Design Suite 11.0»Multisim 11.0. Im Arbeitsbereich wird eine leere 
Datei mit dem Namen Schaltung1 geöffnet. 

So speichern Sie die Datei unter einem anderen Namen: 

1. Wählen Sie Datei»Speichern unter. Es öffnet sich das Windows-
Dialogfeld zum Speichern von Dateien.

2. Wählen Sie einen Speicherort für die Datei aus. Geben Sie anschlie-
ßend als Dateinamen MeineErstenSchritte ein und klicken Sie auf 
die Schaltfläche Speichern.

Tipp Um Datenverlust vorzubeugen, sollten Sie über die Registerkarte Speichern des 
Dialogfelds Allgemeine Einstellungen regelmäßig Sicherungskopien erstellen. 

Zum Öffnen einer vorhandenen Datei gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Datei öffnen, wählen Sie eine Datei aus und 
klicken Sie auf die Schaltfläche Öffnen. 

Tipp Zum Öffnen von Dateien aus älteren Multisim-Versionen wählen Sie im Dialogfeld 
Datei öffnen unter Dateityp die entsprechende Version aus. 

Einfügen der Bauelemente 
Zum Einfügen von Bauelementen gehen Sie wie folgt vor:

1. Öffnen Sie MeineErstenSchritte.ms11 wie oben beschrieben. 

2. Klicken Sie auf Einfügen»Bauelement, um zum Dialogfeld Bau-
element auswählen zu gelangen. Wählen Sie hier die in der folgenden 
Abbildung dargestellte 7-Segment-LED-Anzeige aus und klicken Sie 
auf OK. Das Bauelement erscheint daraufhin umrisshaft unter dem 
Cursor. 

Tipp Nach Auswahl der Gruppe und Familie des Bauelements können Sie unter 
Bauelement den Namen des Bauelements eingeben. Ihre Eingabe wird im Feld Suche 
am unteren Rand des Fensters angezeigt. Geben Sie für das obige Beispiel 
seven_seg_decimal_com_a_blue ein. Übereinstimmungen werden bereits bei der 
Eingabe angezeigt.
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3. Bewegen Sie den Cursor in die rechte untere Ecke der Arbeitsfläche 
und klicken Sie mit der linken Maustaste, um das Bauelement einzu-
fügen. Die Kennung für dieses Bauelement lautet “U1”. 

4. Fügen Sie die restlichen Bauelemente wie dargestellt in den Bereich 
für den Zähler ein. 
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Hinweis Beim Einfügen von Widerständen, Spulen oder Kondensatoren (RLC-Bau-
elementen) enthält das Dialogfeld Bauelement auswählen geringfügig andere Optionen 
als sonst. Beim Einfügen der Bauelemente können Sie eine beliebige Kombination der 
folgenden Parameter wählen: Wert des Bauelements (z. B. Widerstandswert), Typ (z. B. 
Kohleschicht), Toleranz, Footprint und Hersteller. Beim Einfügen eines Bauelements, das 
später in ein PCB-Layout exportiert und in die Stückliste aufgenommen werden soll, müs-
sen Sie darauf achten, dass die im Dialogfeld Bauelement auswählen angegebene 
Kombination von Werten auch wirklich verfügbar ist. 

Tipp Beim Einfügen von RLC-Bauelementen ist der Wert des Bauelements ganz oben in 
die Liste der Bauelemente einzutragen. Der Wert muss aber nicht in der Liste enthalten 
sein, damit das Bauelement in die Schaltung eingefügt werden kann. 

Tipp Um den 200--Widerstand senkrecht anzuordnen, drücken Sie beim Einfügen des 
Widerstands die Tastenkombination <Strg + R>. 

Tipp Die Bauelemente werden in der Reihenfolge, in der sie eingefügt werden, mit Refe-
renzbezeichnern versehen (z. B. U1, U2, U3). Wenn Sie also die Bauelemente in einer 
anderen Reihenfolge als in der Abbildung einfügen, ändert sich auch die Nummerierung 
entsprechend. Dies hat jedoch keinerlei Einfluss auf die Funktion der Schaltung. 
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5. Fügen Sie die Bauelemente für die Steuerung des Zählers ein. Klicken 
Sie nach dem Einfügen mit der rechten Maustaste auf jeden 
SPDT-Schalter und wählen Sie Horizontal spiegeln.

 

Tipp Die SPDT-Schalter befinden sich in der Gruppe Basic und der Familie Switch. 

Tipp Wenn das benötigte Bauelement schon auf dem Schaltplan vorhanden ist, markieren 
Sie es, wählen Sie Bearbeiten»Kopieren und dann Bearbeiten»Einfügen. Sie können es 
außerdem aus der Liste der verwendeten Bauelemente auswählen und durch einen Klick 
in den Schaltplan einfügen. 

6. Fügen Sie die Bauelemente für den Analogverstärker wie dargestellt 
ein und drehen Sie sie bei Bedarf.
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Nachdem Sie die Wechselspannungsquelle eingefügt haben, führen 
Sie einen Doppelklick darauf aus. Ändern Sie den Effektivwert der 
Spannung (RMS) in 0.2 V und klicken Sie auf OK. 

7. Fügen Sie die Bauelemente für die Überbrückungskondensatoren wie 
dargestellt ein.

 

8. Fügen Sie den Kollektor und die dazugehörigen Bauelemente ein (vgl. 
die Abbildung unten).

 

Tipp J3 befindet sich in der Gruppe “Basic” und der Familie “Connectors”.

Tipp Nach dem Verdrahten einer Schaltung können Sie Bauelemente mit zwei Anschlüs-
sen – z. B. Widerstände – einfach auf eine Verbindung legen. Multisim fügt das 
Bauelement dann automatisch in den Stromkreis ein. 
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Verbinden der Bauelemente 
Alle Bauelemente haben Pins, über die sie mit anderen Bauelementen oder 
Geräten verbunden werden können. Sobald sich der Cursor über einem Pin 
befindet, erkennt Multisim die gewünschte Verbindung und der Cursor ver-
wandelt sich in ein Fadenkreuz. 

Tipp Sie können nun entweder die Bauelemente zu einer Schaltung verbinden oder die 
Datei Getting Started 1.ms11 verwenden. Diese befindet sich im Unterordner 
Getting Started des Ordners samples. 

Um Bauelemente zu verbinden, führen Sie die folgenden Schritte aus: 

1. Klicken Sie den Ausgangspunkt für die Verbindung an (der Cursor ver-
wandelt sich daraufhin in ein Fadenkreuz) und bewegen Sie die Maus. 
Daraufhin erscheint unter dem Cursor eine Linie, die eine Leiterbahn 
symbolisieren soll. 

2. Klicken Sie auf den Pin des zweiten Bauelements, an dem die Verbin-
dung enden soll. Multisim erstellt daraufhin eine Leiterbahn und fügt 
diese, wie unten dargestellt, automatisch an der richtigen Stelle und in 
der richtigen Konfiguration ein. Diese Funktion spart insbesondere 
beim Verbinden großer Schaltungen viel Zeit.

 

Tipp Die Lage der Leiterbahn kann durch Mausklicks bestimmt werden. Bei jedem Klick 
wird die Leiterbahn an der entsprechenden Stelle fixiert. 
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3. Verbinden Sie die restlichen Bauelemente für den Zählerbaustein ent-
sprechend der Darstellung. 

 

Tipp Mit Hilfe von Bus-Vektorverbindungen können die Verbindungen von Bau-
elementen mit mehreren Pins (z. B. U3 und R4) als Busleitung geführt werden. Einzelhei-
ten dazu entnehmen Sie bitte der Hilfe zu Multisim. 

Tipp Virtuelle Verdrahtung—Damit die Verbindung nicht zu unübersichtlich wird, 
können Sie zwischen den Abschnitten “Counter Control” und “Digital Counter” virtuelle 
Verbindungen herstellen. Wenn zwei Netze den gleichen Netznamen enthalten, sind sie 
virtuell miteinander verbunden. 
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4. Verdrahten Sie den Rest der Schaltung entsprechend der folgenden 
Abbildung.

 

Simulation 
Durch Simulation einer Schaltung mit Multisim lassen sich schon früh 
Schaltungsfehler erkennen, wodurch Zeit und Geld gespart wird. 

Virtuelle Messinstrumente 
In diesem Abschnitt wird Ihre Schaltung mit Hilfe eines virtuellen Oszillo-
graphen simuliert. 

Tipp Um Zeit zu sparen, können Sie aber auch die Datei Getting Started 2.ms11 aus 
dem Ordner Getting Started verwenden, der sich unter samples befindet. 

1. J1, J2 und R2 sind interaktive Bauelemente. 

Um die Bedientasten für J1, J2 und R2 festzulegen, klicken Sie die 
Bauelemente doppelt an und klicken Sie auf die Registerkarte Wert. 
Geben Sie in das Feld Umschalttaste für J1 E ein, für J2 L und für 
R2 A. 
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2. Zur Aktivierung des Zählers drücken Sie die Taste <E> oder klicken 
Sie auf die verbreiterte Linie, die angezeigt wird, wenn sich der Cursor 
über J1 befindet. 

3. Um einen Oszillographen einzufügen, wählen Sie Simulieren»
Instrumente»Oszillograph. Verbinden Sie das Gerät wie im Schritt 5 
dargestellt mit der restlichen Schaltung. 

Tipp Um einfach zwischen den Kurven auf dem Oszillographen zu unterscheiden, klicken 
Sie die Leitung, die zum Eingang B des Geräts führt, mit der rechten Maustaste an und 
wählen Sie aus dem Kontextmenü die Option Segment einfärben aus. Wählen Sie eine 
andere Farbe als die der Leitung an Eingang A aus, z. B. Blau. (Um die Farbe oder eine 
andere Einstellung zu ändern, muss die Simulation gestoppt werden.)

4. Klicken Sie das Symbol für den Oszillographen doppelt an, um die 
Vorderseite des Geräts mit der Anzeige und den Bedienknöpfen einzu-
blenden. Wählen Sie Simulieren»Start. Im Oszillographen wird nun 
das Ausgangssignal des Operationsverstärkers angezeigt.  

5. Stellen Sie die Skalierung der Zeitbasis auf 2 ms pro Skalenteil und die 
Empfindlichkeit von Kanal A auf 500 mV pro Skalenteil ein. Der 
Oszillograph zeigt die Kurven dann folgendermaßen an:
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Während der Simulation der Schaltung zählt die 7-Segment-Anzeige 
aufwärts. Wenn der Zähler einmal durchgezählt hat, leuchtet eine LED 
auf. 

6. Drücken Sie während der Simulation die Taste <E>, um den Zähler zu 
aktivieren oder zu deaktivieren. Der Aktivierungseingang ist 
low-aktiv. 

Mit <L> wird der Zähler auf Null gestellt. Der Rückstelleingang ist 
ebenfalls low-aktiv. 

Drücken Sie <Shift + A> und beobachten Sie, was beim Verringern des 
Potentiometerwerts geschieht. Wiederholen Sie das Ganze, aber 
drücken Sie diesmal “A”, um den Potentiometerwert zu erhöhen. 

Tipp Statt mit den oben genannten Tasten können Sie die Bauelemente auch mit der Maus 
bedienen. 

Analyse 
In diesem Abschnitt führen Sie an Ihrer Schaltung eine AC-Analyse durch, 
um den Frequenzgang des Verstärkers zu prüfen. 

Zum Durchführen einer AC-Analyse am Ausgang des Operationsverstär-
kers gehen Sie wie folgt vor: 

1. Klicken Sie die Leiterbahn doppelt an, die zum Pin 6 des Operations-
verstärkers führt, und ändern Sie ggf. den Netznamen im Dialogfeld 
Netzwerk in analog_out. 

2. Wählen Sie Simulieren»Analysen»AC-Analyse und klicken Sie auf 
die Registerkarte Ausgabe.
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3. Markieren Sie V(analog_out) in der linken Spalte und klicken Sie 
auf Hinzufügen. Der Eintrag V(analog_out) wird daraufhin in die 
rechte Spalte verschoben. Damit wird die Spannung am Knoten 
V(analog_out) angezeigt.
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4. Klicken Sie auf Simulieren. Die Ergebnisse der Analyse werden in der 
Graphanzeige angezeigt.

Graphanzeige 
In der Graphanzeige können Graphen und Tabellen angezeigt, bearbeitet, 
gespeichert und exportiert werden. In diesem Fenster werden die Ergeb-
nisse aller Multisim-Analysen in Graphen und Diagrammen oder 
Kurvengraphen dargestellt (wie bei einem Oszillographen). 



Kapitel 2 Einführung in Multisim

© National Instruments Corporation 2-17 Erste Schritte mit NI Circuit Design Suite

Zur Anzeige der Simulationsergebnisse in der Graphanzeige gehen Sie 
wie folgt vor: 

1. Starten Sie die Simulation wie oben beschrieben. 

2. Wählen Sie Ansicht»Graphanzeige. 

Postprozessor 
Im Postprozessor können Sie Berechnungen an Analyseergebnissen 
durchführen oder sich die Ergebnisse grafisch anzeigen lassen. Auf die 
Ergebnisse können arithmetische, trigonometrische, logarithmische, 
komplexe und logische Operationen sowie Exponential- und Vektor-
funktionen angewandt werden. 

Berichte 
In Multisim können Berichte unterschiedlichster Art erzeugt werden, z. B. 
Stücklisten (BOMs), Einzelheiten zu Bauelementen, Netzlisten, Schalt-
planstatistiken, Listen unbelegter Gatter oder Querverweisberichte. In 
diesem Abschnitt soll für den Beispielschaltplan eine Stückliste erstellt 
werden. 
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Stückliste 
Eine Stückliste ist eine Aufstellung der Bauelemente, die für eine 
bestimmte Schaltung und die Herstellung der zugehörigen Leiterplatte ver-
wendet werden. Sie enthält folgende Angaben: 

• Stückzahl der benötigten Bauelemente

• Beschreibung einschließlich des Bauelementetyps (z. B. Widerstand) 
und des Werts (z. B. 5,1 kOhm) 

• Referenzbezeichner jedes Bauelements 

• Gehäuse oder Footprint jedes Bauelements 

Zum Erstellen einer Stückliste zu Ihrer Schaltung gehen Sie wie folgt vor: 

1. Wählen Sie Berichte»Stückliste. 

Nun wird die Stückliste geöffnet, die in etwa wie folgt aussieht: 
 

Zum Drucken der Stückliste klicken Sie auf die Schaltfläche Drucken. 
Daraufhin öffnet sich das Windows-Druckdialogfeld, in dem Sie den 
gewünschten Drucker, die Anzahl der Kopien usw. auswählen können.  

Klicken Sie zum Speichern der Stückliste auf die Schaltfläche Speichern. 
Daraufhin öffnet sich das Windows-Dialogfeld zum Speichern von 
Dateien, in dem Sie den Pfad und den Dateinamen angeben können.  
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Da die Stückliste hauptsächlich zur Unterstützung bei der Beschaffung und 
Herstellung gedacht ist, enthält sie keine Bauelemente, die nicht real sind 
oder nicht beschafft werden können, wie z. B. Quellen oder virtuelle Bau-
elemente. Bauelemente, denen kein Footprint zugewiesen ist, erscheinen 
nicht in der Stückliste. 

Wenn Sie eine Liste der Bauelemente in Ihrer Schaltung sehen möchten, 
bei denen es sich nicht um reale Bauelemente handelt, klicken Sie auf die 
Schaltfläche Virtuelle Bauelemente anzeigen. Daraufhin wird ein 
weiteres Fenster geöffnet, in dem nur diese Bauelemente angezeigt werden.  

Weitere Informationen zu Stücklisten und anderen Berichtarten finden Sie 
in der Hilfe zu Multisim. 
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3
Einführung in Ultiboard

In diesem Kapitel wird die praktische Erstellung von Leiterplatten anhand 
der im Multisim-Kapitel beschriebenen Schaltpläne erläutert. 

Tipp Das Importieren von Multisim-Schaltplänen ist in der Hilfe zu Multisim und der 
Hilfe zu Ultiboard beschrieben. 

In Ihrer Ultiboard-Edition sind möglicherweise nicht alle der in diesem 
Kapitel beschriebenen Funktionen vorhanden. Eine Beschreibung Ihrer 
Edition finden Sie in den Versionshinweisen zur NI Circuit Design Suite. 

Ultiboard-Benutzeroberfläche 
Ultiboard ist das Programm der NI Circuit Design Suite, mit dem das 
Layout von Leiterplatten entwickelt wird. Die Circuit Design Suite von 
National Instruments ist ein Softwarepaket zur automatisierten Elektro-
nik-Entwicklung, die Ihnen die wichtigsten Schritte in der 
Schaltungsentwicklung erleichtert. 

Ultiboard erzeugt anhand der Daten von Multisim gedruckte Schaltungen, 
führt einfache mechanische CAD-Arbeitsschritte durch (z. B. Platzierung 
der Bauelemente auf den Leiterplatten) und bereitet die Leiterplatten für 
die Produktion vor. Außerdem bietet das Programm automatisierte 
Funktionen für Bestückung und Leiterplattenentwurf. 
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Die Benutzeroberfläche von Ultiboard ist folgendermaßen aufgebaut: 
 

Die Menüleiste enthält die Befehle für sämtliche Funktionen. 

Die Symbolleiste Standard enthält Schaltflächen für die meistverwende-
ten Funktionen wie Speichern, Drucken, Ausschneiden oder Einfügen. 

1 Menüleiste
2 Symbolleiste “Standard”
3 Symbolleiste “Auswahl”
4 Symbolleiste “Zeicheneinstellungen”
5 Symbolleiste “Ansicht”

6 Hauptleiste
7 Symbolleiste “Autom. Leiterbahnführung”
8 Statusleiste
9 Arbeitsbereich

10 Tabellenansicht
11 Schaltungs-

werkzeuge
12 3D-Vorschau
13 Vogelperspektive
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Je mehr Bauelemente und Leiterbahnen Sie einer Leiterplatte hinzufügen, 
desto schwieriger wird es, ein bestimmtes Objekt zu markieren. Die Sym-
bolleiste Auswahl enthält Schaltflächen, die das Markieren von Objekten 
vereinfachen sollen. 

Die Symbolleiste Zeicheneinstellungen ermöglicht Ihnen die Auswahl der 
Lage, Dicke und Messgröße gezeichneter Linien oder Objekte. Außerdem 
bietet sie Schaltflächen für Funktionen, mit denen die Darstellung von 
Linien und Formen auf einer Lage geändert werden kann. 

Die Symbolleiste Ansicht enthält Schaltflächen zum Ändern der 
Bildschirmanzeige.

Die Hauptleiste enthält Schaltflächen für allgemeine 
Leiterplattenfunktionen.

Die Symbolleiste Automatische Leiterbahnführung enthält Funktionen 
zum Autorouting und zur Bauelementplatzierung. 

Die Statusleiste zeigt wichtige Informationen an. 

Der Arbeitsbereich enthält Ihre Schaltung. 

Mit der Tabellenansicht können Sie Angaben zu Bauelementen abfragen 
und ändern, z. B. Platzbedarf, Referenzbezeichnung, Attribute oder 
Beschränkungen. 

Mit den Schaltungswerkzeugen können Sie Teile der Schaltung ein- und 
ausblenden oder abdunkeln.

Mit der 3D-Vorschau erhalten Sie eine dreidimensionale Vorschau der 
Leiterplatte. 

Mit Vogelperspektive wird die Schaltung zur besseren Übersicht bild-
schirmfüllend angezeigt. 

Öffnen der Einführung 
Zum Öffnen der Übungsdatei gehen Sie wie folgt vor: 

1. Starten Sie Ultiboard über Start»Alle Programme»National 
Instruments»Circuit Design Suite 11.0»Ultiboard 11.0.

2. Wählen Sie Datei»Beispieldatei öffnen und klicken Sie doppelt auf 
den Ordner Getting Started. 
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3. Wählen Sie GettingStarted.ewprj und klicken Sie auf Öffnen. 
Die Projektdatei wird in Ultiboard geladen. 

4. Zum Auswählen eines Schaltplans aus dem Projekt (z. B. GS1) klicken 
Sie entweder auf die dazugehörige Registerkarte oder wählen Sie auf 
der Registerkarte Projekte der Schaltungswerkzeuge den Namen des 
Schaltplans aus. 

Auswahl des Leiterplattenumrisses 
Zwar ist bereits ein Leiterplattenumriss eingestellt, aber wenn dieser für Ihre 
Bauelemente ungeeignet ist, können Sie einen anderen auswählen, z. B.:

• durch Ziehen eines Leiterplattenumrisses mit Hilfe der 
Zeichenwerkzeuge 

• durch Importieren einer DXF-Datei

• mit Hilfe des Leiterplattenassistenten.
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Um mit dem Leiterplattenassistenten zu arbeiten, führen Sie die folgen-
den Schritte aus:

1. Klicken Sie auf der Registerkarte Lagen doppelt auf 
Leiterplattenumriss.

2. Klicken Sie in der Schaltung GS1 auf die vorhandene Kontur und 
drücken Sie die Taste <Entf>. 

3. Wählen Sie Extras»Leiterplattenassistent. 
 

4. Aktivieren Sie die Option Lagentechnologie ändern, um zu den ande-
ren Optionen zu gelangen. 

5. Wählen Sie Mehrere Lagen mit doppelseitigen Leiterplatten und 
Einzellagenstapeln aus und klicken Sie auf Weiter. 

6. Im nachfolgenden Dialogfeld können Sie Überschichtungseinstel-
lungen für die Leiterplatte vornehmen (bei dieser Übung wird jedoch 
keine Einstellung geändert). 
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7. Klicken Sie auf Weiter. 

Im Dialogfeld Leiterplattenassistent - Leiterplattenform:

• muss der Bezugspunkt zur Ausrichtung auf Unten links gesetzt 
sein.

• muss die Option Rechteckig aktiviert sein.

• muss die Breite auf 3000 und die Höhe auf 2000 eingestellt 
werden (diese Größe ist für die Bauelemente in diesem Schaltplan 
besser geeignet).

• muss der Freiraum 5,00000 lauten. Dieser Wert gibt die Breite 
des freizuhaltenden Leiterplattenrands an.

8. Klicken Sie auf Fertigstellen. Der Leiterplattenumriss wird Ihrem 
Entwurf hinzugefügt.

Hinweis Weitere Einzelheiten zum Leiterplattenassistenten erhalten Sie in der Hilfe zu 
Ultiboard. 

Um den Leiterplattenumriss zu verschieben, führen Sie die folgenden 
Schritte aus:

1. Klicken Sie auf der Registerkarte Lagen doppelt auf 
Leiterplattenumriss.

2. Klicken Sie dann an eine beliebige Stelle im Leiterplattenumriss und 
ziehen Sie die Leiterplatte direkt unter die Bauelemente.
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Um den Referenzpunkt zu ändern, gehen Sie wie folgt vor:

1. Wählen Sie Entwurf»Referenzpunkt festlegen. Damit wird der 
Referenzpunkt dem Cursor unterlegt.

2. Führen Sie den Cursor in die linke untere Ecke des Leiterplattenumris-
ses und führen Sie zum Einfügen des Referenzpunkts einen Mausklick 
aus.

 

Platzieren von Bauelementen 
Zum Einfügen der Bauelemente in die Leiterplatte GS1 gibt es verschie-
dene Möglichkeiten: 

• Wählen Sie Bauelemente aus dem Bereich außerhalb des Leiter-
plattenumrisses aus und ziehen Sie sie an die gewünschte Stelle. 

• Suchen Sie die Bauelemente auf der Registerkarte Bauelemente in der 
Tabellenansicht und fügen Sie sie von dort aus ein. 

• Wählen Sie Bauelemente aus der Datenbank aus. 

Tipp Mit Einfügen»Platzierung von Bauelementen aufheben können Sie alle nicht 
fixierten Bauelemente von der Leiterplatte entfernen und sie noch einmal auf eine andere 
Weise einfügen. 
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Verschieben von Bauelementen in den belegbaren Leiterplattenbereich 
Beim Öffnen einer Netzliste aus Multisim oder eines anderen Programms 
zum Erstellen von Schaltplänen werden die Bauelemente normalerweise 
außerhalb des Leiterplattenumrisses angeordnet. 

Klicken Sie vor dem Beginn der Arbeit unter Schaltungswerkzeuge dop-
pelt auf Kupferfläche oben. Dadurch wird diese Lage als aktive Lage 
ausgewählt. 

Um U1 aus dem Bereich außerhalb des Leiterplattenumrisses zu verschie-
ben, führen Sie die folgenden Schritte aus: 

1. Suchen Sie in den Bauelementen außerhalb des Leiterplattenumrisses 
nach U1. Zoomen Sie dazu den Bereich mit <F8> heran, bis Sie U1 
erkennen können. 

Tipp Mit Hilfe der Funktion Bearbeiten»Suchen können Sie nach einem Bauelement 
suchen. Diese Funktion arbeitet im Großen und Ganzen wie die Suchfunktion anderer 
Anwendungen. Zusätzlich können Sie ein Bauelement jedoch auch nach Namen, Nummer, 
Form, Wert oder nach all diesen Parametern ausfindig machen. Weitere Informationen 
dazu finden Sie in der Hilfe zu Ultiboard. 
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2. Klicken Sie auf U1 (die 7-Segment-Anzeige) und ziehen Sie sie an die 
in der unteren Abbildung gezeigte Position. 

 

U1 bleibt so lange ausgewählt, bis Sie die Markierung aufheben. In 
Ultiboard müssen Sie jeden Vorgang beenden, bevor Sie fortfahren 
können. In diesem Fall wird die Auswahl des Bauelements durch einen 
Klick an eine andere Stelle aufgehoben. Auch durch einen Klick mit 
der rechten Maustaste kann der aktuelle Vorgang beendet werden. 

3. Klicken Sie auf die Registerkarte Bauelemente in der Tabellen-
ansicht und scrollen Sie zu U1. Sie werden feststellen, dass die grüne 
LED neben dem Bauelement etwas heller leuchtet – dadurch wird 
angezeigt, dass das Bauelement bereits auf die Leiterplatte platziert 
wurde. 

1 Kraftvektor 2 Luftlinie
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Ziehen von Bauelementen aus der Registerkarte “Bauelemente” in die 
Schaltung 

Um Bauelemente aus der Registerkarte Bauelemente an eine andere Stelle 
zu ziehen, gehen Sie wie folgt vor: 

1. Scrollen Sie auf der Registerkarte Bauelemente zu J3. 
 

2. Klicken Sie auf J3 und ziehen Sie das Element von der Registerkarte 
Bauelemente in den Arbeitsbereich. J3 ist nun dem Mauszeiger 
unterlegt. 

3. Legen Sie J3 links am Rand etwa mittig auf der Leiterplatte ab. Wie 
bereits zuvor beobachtet, leuchtet nun auch die grüne LED von J3 auf 
der Registerkarte Bauelemente etwas heller und zeigt damit an, dass 
das Bauelement auf der Leiterplatte platziert wurde. 

Einfügen der Bauelemente dieser Einführung 
Die Leiterplatte sollte am Schluss der Übung so bestückt sein wie in der fol-
genden Abbildung. Die genaue Vorgehensweise bleibt Ihnen überlassen. 
Sie können aber auch die Datei GS2 in Ihrem Projekt öffnen, die bereits ent-
sprechend vorbereitet wurde. 
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Ihre Schaltung sollte wie folgt aussehen: 
 

Einfügen von Bauelementen aus der Datenbank 
Statt Bauelemente und andere Komponenten aus einer Datei zu importie-
ren, können Sie sie auch direkt aus der Datenbank in die Leiterplatte 
einfügen. Im Folgenden wird auf diese Weise eine Montagebohrung 
vorgenommen. 

Zum Einfügen von Bauelementen aus der Datenbank gehen Sie wie folgt 
vor:

1. Wählen Sie Einfügen»Aus Datenbank. Daraufhin öffnet sich das 
Dialogfeld Bauelement aus Datenbank abrufen.  

2. Erweitern Sie unter Datenbank die Kategorie Through Hole Tech-
nology Parts und wechseln Sie zur Kategorie Holes. Die 
Komponenten werden daraufhin unter Verfügbare Bauelemente 
angezeigt. 
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3. Klicken Sie unter Verfügbare Bauelemente auf Hole35. Die Kompo-
nente wird daraufhin in der Vorschau angezeigt. 

 

4. Klicken Sie auf OK. Das Dialogfeld Bauelement aus Datenbank 
abrufen wird ausgeblendet und Sie werden dazu aufgefordert, einen 
Referenzbezeichner (RefBez) und einen Wert einzugeben. 

5. Geben Sie als Referenzbezeichner des Bohrlochs “H1” und als Wert 
“HOLE” ein und klicken Sie auf OK. 

6. Bewegen Sie den Mauszeiger über die Leiterplatte. Die Komponente 
ist nun dem Mauszeiger unterlegt.

7. Sobald sich das Loch im Bereich der oberen linken Ecke befindet, 
legen Sie es durch einen Mausklick auf der Leiterplatte ab. 

8. Es erscheint erneut das Dialogfeld Referenzbezeichnung für Bauele-
ment eingeben. Der Referenzbezeichner wird automatisch auf H2 
erhöht. 

9. Geben Sie als Wert “HOLE” ein und klicken Sie auf OK, um die näch-
ste Bohrung in der rechten oberen Ecke zu platzieren und fahren Sie so 
mit H3 in der rechten unteren Ecke und H4 in der linken unteren Ecke 
fort. 
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10. Klicken Sie zum Beenden des Vorgangs auf Abbrechen und schließen 
Sie das Dialogfeld Bauelement aus Datenbank abrufen, indem Sie 
nochmals auf Abbrechen klicken. 

 

Bauelemente verschieben 
Die verschiedenen Vorgehensweisen zum Einfügen von Bauelementen 
gelten ebenso für das Verschieben. Um ein Bauelement auszuwählen, das 
sich bereits auf der Leiterplatte befindet, müssen Sie nur darauf klicken. 
Zum Festlegen der Koordinaten, an die das Bauelement verschoben werden 
soll, drücken Sie auf dem Ziffernblock der Tastatur die <*>-Taste. Statt-
dessen können Sie auch auf der Registerkarte Bauelemente ein platziertes 
Bauelement auswählen (durch eine hell leuchtende grüne LED gekenn-
zeichnet) und es an eine andere Stelle ziehen.

Tipp Die Beschriftung von Bauelementen gehört nicht zum Footprint. Beim Markieren 
eines Bauelements auf der Leiterplatte müssen Sie daher aufpassen, dass Sie das gesamte 
Bauelement markieren und nicht nur die Beschriftung. Um diesen Vorgang zu erleichten, 
können Sie die Auswahlfilter zu Hilfe nehmen. Weitere Informationen finden Sie in der 
Hilfe zu Ultiboard. 
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Tipp Zum Verschieben eines Bauelements markieren Sie es und drücken Sie die Pfeil-
tasten auf der Tastatur. 

Sie können aber auch mehrere Bauelemente markieren und gemeinsam 
verschieben. Dazu gibt es folgende Möglichkeiten: 

• Drücken Sie die <Shift>-Taste und klicken Sie mehrere Bauelemente an.

• Ziehen Sie um mehrere Bauelemente einen Rahmen auf. 

Alle markierten Bauelemente werden beim Bewegen des Cursors gemein-
sam verschoben.

Tipp Die Gruppen gelten jedoch nur vorübergehend – sobald Sie ein anderes Bauelement 
auswählen, geht die Gruppierung verloren. Um eine Gruppe von Bauelementen dauerhaft 
(bis zum Entfernen) zusammenzuhalten, ist der Gruppeneditor zu verwenden. Weitere 
Informationen finden Sie in der Hilfe zu Ultiboard. 

Durch Bearbeiten»Ausrichten können markierte Bauelemente so ver-
schoben werden, dass ihre Ränder in einer Linie sind oder die Bauelemente 
einen bestimmten Abstand voneinander haben. 

So platzieren Sie das eingefügte Bohrloch durch Bearbeiten»Ausrichten 
an die richtige Stelle: 

1. Wählen Sie H1 und halten Sie für H2 die Shift-Taste gedrückt. 

2. Wählen Sie Bearbeiten»Ausrichten»Oben ausrichten. Wenn H2 
nicht in Linie mit H2 eingefügt wurde, wird es nun entsprechend 
verschoben. 

3. Klicken Sie auf einen freien Bereich auf der Leiterplatte und markieren 
Sie H2 und H3. 

4. Wählen Sie Bearbeiten»Ausrichten»Rechts ausrichten. 

5. Fahren Sie auf diese Weise mit dem Ausrichten der Unterkanten von 
H3 und H4 sowie der linken Kanten von H1 und H4 fort. 

Verlegen von Leiterbahnen 
Zum Verlegen von Leiterbahnen stehen Ihnen die folgenden Optionen zur 
Verfügung: 

• Manuell eingefügte Leiterbahn 

• Follow-me-Leiterbahn 

• Vollautomatisch eingefügte Leiterbahn 
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Eine manuell eingefügte Leiterbahn wird genau so verlegt, wie Sie es vor-
geben, auch wenn sie durch ein Hindernis verläuft. Eine Follow-me-
Leiterbahn stellt selbständig zulässige Verbindungen zwischen den mit der 
Maus angewählten Pins her. Sie können die Maus also von Pin zu Pin bewe-
gen und so eine Leiterbahn anlegen. Beim vollautomatischen Einfügen von 
Leiterbahnen werden zwei Pins auf dem kürzestmöglichen Weg miteinan-
der verbunden, wobei der Verlauf der Leiterbahn nachträglich von Hand 
geändert werden kann. 

Bevor Sie mit der Maus klicken, um eine Leiterbahn an einer bestimmten 
Stelle zu fixieren, können Sie jederzeit ein Stück der Leiterbahn entfernen, 
indem Sie den Cursor zurückbewegen. Ein neues Segment wird immer 
dann erzeugt, wenn Sie durch Mausklicks eine Leiterbahn manuell verle-
gen oder wenn eine (halb-)automatisch verlegte Leiterbahn die Richtung 
ändert. Dieser Umstand ist bei Änderungen an Leiterbahnen zu 
berücksichtigen. 

Manuelles Verlegen von Leiterbahnen 
Sie können entweder mit der bisher verwendeten Datei fortfahren oder GS3 
öffnen. Vergewissern Sie sich, dass Sie sich auf der Kupferfläche oben 
befinden, bevor Sie beginnen. Die Kupferfläche oben sollte auf der 
Registerkarte Lagen der Schaltungswerkzeuge rot hervorgehoben sein. 

Tipp Drücken Sie bei Bedarf zum Einblenden des gesamten Plans die Taste <F7>. 

Zum manuellen Verlegen einer Leiterbahn gehen Sie wie folgt vor: 

1. Wählen Sie Einfügen»Linie. 

Tipp Mit dem Menüpunkt Linie wird auf einer beliebigen Lage eine Linie erzeugt. Die 
Art der Linie ist je nach ausgewählter Lage unterschiedlich. Wenn die ausgewählte Lage 
zum Beispiel die Siebdrucklage ist, wird damit auf der Siebdrucklage eine Linie erzeugt. 
Bei einer Kupferlage wird mit dieser Option eine leitende Verbindung hergestellt. 
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2. Suchen Sie links auf der Leiterplatte nach J3. Finden Sie heraus, wo 
sich der unten gezeigte Start-Pin befindet: 

 

Tipp Die Kraftvektoren können ausgeblendet werden, so dass die Netze deutlicher sicht-
bar sind. Deaktivieren Sie dazu die Option Kraftvektoren auf der Registerkarte Lagen der 
Schaltungswerkzeuge. Weitere Informationen zu Kraftvektoren finden Sie in der Hilfe 
zu Ultiboard. 

Tipp Bei Schwierigkeiten mit dem Auffinden des Bauelements nutzen Sie die Suchfunk-
tion auf der Registerkarte Bauelemente. Wählen Sie das Bauelement auf der Registerkarte 
Bauelemente aus und klicken Sie dann die Schaltfläche Bauelement suchen und aus-
wählen an. Das Bauelement wird im Arbeitsbereich angezeigt. Bei Bedarf können Sie mit 
<F8> näher heranzoomen. 

3. Klicken Sie auf den Pin, der im Schritt oben festgelegt wurde. 
Ultiboard hebt daraufhin alle Pins hervor, die zum selben Netz gehö-
ren. Die Hervorhebungsfarbe kann auf der Registerkarte Farben des 
Dialogfelds Einstellungen geändert werden. So wissen Sie, welche 
Pins Ihrem Schaltplan entsprechend zu verbinden sind. 

1 Bauelement J3 2 Start-Pin
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4. Bewegen Sie den Cursor in eine beliebige Richtung. Eine grüne Linie 
(die Leiterbahn) wird nun an den ausgewählten Pin angefügt. Mit 
jedem Klick fixieren Sie ein Leiterbahnensegment, wie in der folgen-
den Abbildung dargestellt. 

5. Klicken Sie auf den Pin, an dem die Verbindung enden soll. 
 

6. Mit einem Rechtsklick wird das Verlegen von Leiterbahnen beendet. 

7. Um den Modus zum Verlegen von Leiterbahnen zu beenden, klicken 
Sie in der Hauptleiste auf die Schaltfläche Markieren.  

1  Pins desselben Netzes  

1 Leiterbahn
2 Zum Fixieren der Leiterbahn klicken

3 Endpunkt
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Verlegen von Follow-me-Leiterbahnen 
Zum Verlegen einer Follow-me-Leiterbahn gehen Sie wie folgt vor: 

1. Wählen Sie Einfügen»Follow-me.  

2. Klicken Sie auf den oberen Pin von J3. 

3. Klicken Sie auf der linken Seite von U4 auf den zweiten Pin von unten. 

4. Ultiboard stellt automatisch eine Verbindung zwischen den Pins her. 

Tipp Anstelle der Pins können Sie auch die Luftlinienverbindung zwischen den Bau-
elementen anklicken. 

Vollautomatisches Verlegen von Leiterbahnen 
Zum vollautomatischen Verlegen von Leiterbahnen gehen Sie wie folgt 
vor:

1. Wählen Sie Einfügen»Vollautomatisch.  

2. Klicken Sie auf die unten dargestellte Luftlinie. 
 

3. Beim Bewegen Ihres Cursors schlägt Ultiboard automatisch verschie-
dene Leiterbahnverläufe um Hindernisse herum vor. 

1 Luftlinie anklicken  
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4. Wenn Sie sich für eine Leiterbahnführung entschieden haben, fixieren 
Sie die Leiterbahn durch einen Klick. Sie müssen dazu nicht auf die 
Luftlinie oder den Pin klicken, an dem die Verbindung enden soll. 

 

5. Mit einem Rechtsklick beenden Sie die Leiterbahnplatzierung. 

Automatische Bestückung 
Neben den bisher beschriebenen Möglichkeiten zum Bestücken von Leiter-
platten bietet Ultiboard eine vollautomatische 
Bauelement-Platzierungsfunktion für fortgeschrittene Benutzer. 

Tipp Vor dem automatischen Bestücken der Leiterplatte müssen Sie alle Bauelemente, die 
vom automatischen Einfügen nicht betroffen sein sollen, per Hand einfügen und an der 
gewünschten Stelle fixieren. (Die Montagebohrungen und U1, J1, J2, J3, und LED 1 in GS5 
wurden beispielsweise bereits fixiert). Weitere Informationen zum Fixieren von Bau-
elementen finden Sie in der Hilfe zu Ultiboard. 

1 Leiterbahnsegmente zwischen Pins  
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Zum automatischen Einfügen der Bauelemente in Getting Star-
ted.ewprj gehen Sie folgendermaßen vor:

1. Öffnen Sie den Entwurf GS5 in Ultiboard. 

2. Wählen Sie Automatische Leiterbahnführung»Automatische 
Bestückung starten. Die Leiterplatte wird nun mit den Bauelementen 
bestückt.

 

Automatische Leiterbahnführung 
Leiterbahnen können in Ultiboard entweder nach den bisher beschriebenen 
Verfahren oder automatisch verlegt werden. Die automatische Leiterbahn-
führung wird nachfolgend erklärt. 

Zum automatischen Verbinden der Leiterbahnen in Getting Star-
ted.ewprj gehen Sie wie folgt vor: 

1. Öffnen Sie in Ultiboard die Schaltung GS3. 

2. Wählen Sie Automatische Leiterbahnführung»Automatische Lei-
terbahnführung starten/fortsetzen. Der Arbeitsbereich wechselt in 
den Modus der automatischen Leiterbahnführung. 

Daraufhin können Sie sehen, wie die Leiterbahnen auf der Leiterplatte 
verlegt werden. Nach Abschluss des Vorgangs wechselt Ultiboard 
zurück zum Arbeitsbereich.
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3. Bei Bedarf können Sie den Verlauf der Leiterbahnen optimieren, 
indem Sie Automatische Leiterbahnführung»Optimierung starten 
auswählen. 

 

Sie können die automatische Leiterbahnführung jederzeit anhalten und 
manuelle Änderungen vornehmen. Bei erneutem Start der automatischen 
Leiterbahnführung fährt die Funktion an der letzten Stelle fort. Alle manu-
ell verlegten Leiterbahnen müssen fixiert werden, damit sie nicht durch die 
Automatik verschoben werden. 

Tipp Die Einstellungen zum automatischen Bestücken mit Bauelementen und zur auto-
matischen Leiterbahnführung befinden sich in den Leiterbahnführungsoptionen. 
Weitere Informationen dazu finden Sie in der Hilfe zu Ultiboard. 

Vorbereitung für die Leiterplattenfertigung 
Ultiboard bietet eine Vielzahl verschiedener Ausgabeformate für die Pro-
duktion und Fertigung der Leiterplatte. In diesem Abschnitt werden das 
Fertigen der Leiterplatte und Dokumentieren des gefertigten Produkts 
beschrieben. 



Kapitel 3 Einführung in Ultiboard

Erste Schritte mit NI Circuit Design Suite 3-22 ni.com

Aufräumen der Leiterplatte (Clean-Up) 
Bevor Sie die Leiterplatte in die Fertigung schicken, sollten Sie alle offenen 
Leiterbahnenden und nicht genutzten Lötaugen von der Leiterplatte 
beseitigen. 

Das Löschen offener Leiterbahnenden soll nun anhand der Schaltung GS4 
geübt werden. Öffnen Sie die Datei und wählen Sie Bearbeiten»Kupfer-
flächen löschen»Offene Leiterbahnenden. Dadurch werden alle offenen 
Leiterbahnen aus der Schaltung gelöscht. 

Zum Löschen ungenutzter Durchkontaktierungen vergewissern Sie sich 
zunächst, dass die Schaltung geöffnet ist, und wählen Sie dann Schal-
tung»Ungenutzte Durchkontaktierungen löschen. Daraufhin werden 
alle Durchkontaktierungen ohne dazugehörige Leiterbahnen oder Kupfer-
flächen gelöscht. 

Hinzufügen von Kommentaren 
Mit Hilfe von Kommentaren können Sie Änderungsaufträge oder Hinter-
grundinformationen an die Ingenieursabteilung übermitteln. 

Sie können einen Kommentar in die Schaltung einfügen oder direkt an ein 
Bauelement anheften. Wenn Sie das betreffende Bauelement verschieben, 
so verschiebt sich der Kommentar ebenfalls. 

Weitere Informationen finden Sie in der Hilfe zu Ultiboard. 

Exportieren von Dateien 
Eine Exportdatei enthält umfassende Angaben zur Fertigung einer Leiter-
platte. Zu den exportierbaren Dateien gehören Gerber-RS-274X- und 
RS-274D-Dateien. 

Alle weiteren Informationen finden Sie in der Hilfe zu Ultiboard. 
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3D-Ansicht von Schaltungen 
In Ultiboard kann jederzeit eine dreidimensionale Voransicht der Leiter-
platte eingeblendet werden. Alle weiteren Informationen finden Sie in der 
Hilfe zu Ultiboard. 

 

Tipp Die Innenansicht ermöglicht Ihnen einen Blick zwischen die Lagen einer mehr-
lagigen Leiterplatte. Weitere Informationen finden Sie in der Hilfe zu Ultiboard. 
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4
Einführung in Multisim MCU

In diesem Kapitel wird die Simulation einer Schaltung mit Mikrocontroller 
und die Fehlersuche in einer solchen Schaltung beschrieben. 

Einige der hier genannten Funktionen sind möglicherweise nicht in Ihrer 
Version der Circuit Design Suite verfügbar. Eine Beschreibung Ihrer 
Edition finden Sie in den Versionshinweisen zur NI Circuit Design Suite. 

Überblick 
Die für diese Einführung verwendeten Dateien werden zusammen mit der 
NI Circuit Design Suite Software unter ...\Dokumente und 
Einstellungen\All Users\Gemeinsame Dokumente\National 

Instruments\Circuit Design Suite 11.0\samples\Getting 

Started installiert. 

Für diese Anleitung nutzen Sie die Datei Getting Started MCU.ms11, 
die bei Bedarf auf den Inhalt des Ordners LCDWorkspace zugreift. 

Im Multisim-Schaltungsbeispiel für eine LCD-Grafikanzeige wird der Ein-
satz eines PIC-Mikrocontrollers zur Steuerung der Anzeige anhand eines 
Toshiba-T6963C-Controllers und einem externen RAM-Speichers 
demonstriert. Zur Steuerung der Anzeige übermittelt der Mikrocontroller 
Signale über die Daten- und Steuerleitungen des Geräts. Ein für den Mikro-
controller entwickeltes Softwareprogramm bestimmt die Pin-Logikpegel 
(High oder Low), mit deren Hilfe Befehle und Daten an die Anzeige über-
mittelt werden. 
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Über diese Anleitung 
Die Datenleitungen von LCD U2 sind mit den Pins RB0 bis RB7 des 
Mikrocontrollers U1 verbunden. Die Steuerleitungen des LCD sind mit 
RA0 bis RA2 des Mikrocontrollers verbunden. Die MCU U1 kommuni-
ziert mit dem LCD U2 über diese Verbindungen. Die Daten werden parallel 
an U2 übermittelt, wobei die Signale auf den Steuerleitungen das Timing 
und den Typ der gesendeten Daten (Adresse oder Daten) bestimmen. 

Die LCD-Grafikanzeige kann im Textmodus, Grafikmodus oder einem 
kombinierten Modus für Text und Grafik betrieben werden. Im Beispiel 
befindet sich die Anzeige im kombinierten Modus. Die Software zur Aus-
führung der MCU befindet sich in einem MCU-Arbeitsbereich, der unter 
Schaltungswerkzeuge als LCDWorkspace angezeigt wird. Der Arbeitsbe-
reich enthält ein Projekt namens project1, das nur aus der Quellcodedatei 
main.asm besteht.  
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Zum Öffnen der Datei gehen Sie wie folgt vor:

1. Klicken Sie unter Schaltungswerkzeuge doppelt auf main.asm. Im 
Arbeitsbereich erscheint daraufhin eine Registerkarte mit dem Namen 
main.asm, auf der das Assembler-Programm angezeigt wird. 

 

Zum Einblenden der Zeilennummern wählen Sie MCU»Zeilennummern 
anzeigen. 

Zum Ausführen der Schaltung gehen Sie wie folgt vor: 

1. Wählen Sie Simulieren»Start. Wenn Sie noch keine Programmdatei 
erzeugt haben, wird ein Dialogfeld mit dem Hinweis angezeigt, dass 
die Konfiguration nicht mehr aktuell ist. Sie werden daher zum Erstel-
len einer Programmdatei aufgefordert. Klicken Sie auf Ja. Die 
Ergebnisse des Build-Prozesses werden in der Tabellenansicht auf 
der Registerkarte Ergebnisse angezeigt.  

Gehen Sie zur Schaltung zurück. Das Programm zeigt die Zeile 
“Graphical LCD T6963C for Multisim” im Textmodus an; das LCD 
schaltet dann in den Grafikmodus um und stellt Punkt für Punkt über 
dem Text ein umgedrehtes “V” dar. 

Nach der Anzeige der Linien scrollt der Text nach rechts und links.  
Dazu wird einfach die Startadresse des Textpuffers der LCD-Anzeige 
verschoben. Die Anzeige enthält zwei Pufferspeicher, und zwar einen 
zum Speichern von Grafiken und einen zum Speichern von Texten. 
Weitere Funktionen der LCD-Anzeige, wie Blinken des Textes und 
Löschen von Zeichen, werden ebenfalls demonstriert. 

Das Programm zur Steuerung der LCD-Anzeige stellt jeden dieser 
Effekte nacheinander dar. 

Um die Simulation anzuhalten, wählen Sie Simulieren»Stopp.  
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Funktionsweise des Assembler-Programms 
Konstanten und Daten
Wechseln Sie zur Datei main.asm. 

Um das Programm verständlicher zu gestalten, werden zu Beginn die 
Befehle zur Steuerung der Anzeige und die temporären Puffer für Adressen 
und Daten in der MCU als Konstanten definiert.

 

Der anzuzeigende Text wird bei einigen Mikrocontrollern in Form einer 
Tabelle gespeichert. Es gibt aber keinen Assembler-Befehl, um direkt auf 
einen Datenwert im Speicherbereich des Programms zuzugreifen. Stattdes-
sen besteht die Möglichkeit, Werte uncodiert in das W-Register zu laden. 
So können Sie eine Routine schreiben, die je nach Kennzahl einen anderen 
String ausgibt. Die RETLW-Anweisung lädt einen konstanten Wert in das 
W-Register und führt einen RETURN durch (beides in einem Befehl).  

Die TXPRT-Routine fragt den auf der LCD-Anzeige darzustellenden Text ab. 
Die Zeichencodes der LCD-Anzeige sind im Handbuch zum T6963C-
Controller festgehalten (z. B. 0x27 steht für “G” und 0x52 für “r”). 
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Initialisierung
Der Initialisierungscode beginnt bei START, wie im Programmabschnitt 
unten dargestellt. Die Pins des Mikrocontrollers werden als Ausgangs-
kontakte konfiguriert und die Werte zurückgesetzt. Die LCD-Anzeige wird 
durch den Mikrocontroller initialisiert und auf Grafik- und Textmodus 
gestellt. Die Rücksprungadresse wird für den Grafikpuffer auf 0x0000 und 
den Textpuffer auf 0x2941 eingestellt. Dadurch wird festgelegt, an wel-
cher Stelle im LCD die Anzeige die Daten beginnen soll. Schließlich 
werden die Steuersignale noch für den geeigneten Schreib-/Lesezugriff auf 
der LCD-Anzeige eingestellt. 
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Darstellen von Text und Grafiken
Der Rest des Programmcodes dient dazu, Befehle über die Steuerleitungen 
und die Mikrocontroller-Pins (RA0 bis RA2) an die LCD-Anzeige zu über-
mitteln und die Daten über die Datenleitungen zu senden: 

 

Zum Beispiel werden mit dem oben dargestellten Programmabschnitt die 
mit der TXPRT-Subroutine angegebenen Zeichen aus der Hauptschleife an 
die im Textmodus befindliche LCD-Anzeige übertragen. 

Mit den folgenden Befehlen wird die LCD-Anzeige in den Auto-Schreib-
modus umgeschaltet: 

MOVLWCMD_AWRON

MOVWFCMD_BUFFER

CALLCMD
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An diesem Punkt beginnt das Programm zu zählen und führt die Schleife 
LOOP_READ_DATA2 35 Mal aus. Durch TXPRT ruft die Schleife den Text ab 
und lädt ihn in das W-Register. Dann ruft sie die Subroutine ADT auf, 
welche wiederum SEND_DATA aufruft. Dadurch werden die Werte im 
W-Register an den Anschluss B gesendet, so dass sie an die Datenleitungen 
der LCD-Anzeige übermittelt werden können. Nach dem Senden der Daten 
wird der Eigenwert von Anschluss A des Mikrocontrollers an die Steuer-
kontakte der LCD-Anzeige übertragen, um zu signalisieren, dass die Daten 
gelesen werden können. Nach Ausführung jeder Subroutine kehrt das Pro-
gramm wieder an das Ende des letzten Befehls zurück, der vor dem Aufruf 
der Subroutine ausgeführt wurde. Das passiert so lange, bis alle 35 Zeichen 
übermittelt wurden. Mit den letzten drei Anweisungen wird nach Verlassen 
der Schleife der Auto-Schreibmodus der LCD-Anzeige ausgeschaltet: 

MOVLWCMD_AWROFF

MOVWFCMD_BUFFER

CALLCMD

Mit den folgenden Anweisungen wird die horizontale und die schräge Linie 
im Grafikmodus gezeichnet:

;6 draw wave once

MOVFADDR_L, 0

BTFSCSTATUS, Z

CALLDRAW_WAVE

MCU-Fehlersuchfunktionen 
Dieser Abschnitt enthält eine Schritt-für-Schritt-Beschreibung der 
Multisim-Fehlersuchfunktion für MCUs. Es ist wichtig, dass die Schritte 
genau in der angegebenen Reihenfolge ausgeführt werden. Sobald Sie mit 
der Haltepunktfunktion und dem Einzelschrittverfahren vertraut sind, kön-
nen Sie sich mit den komplexeren Fehlersuchfunktionen befassen. 

Übersicht zur Fehlersuche 
Um ein Programm für einen Mikrocontroller entweder in C oder Assembler 
zu schreiben, erstellen Sie zunächst Quellcodedateien, also eine *.asm-, 
*.inc-, *.c- und *.h-Datei, als Teil des MCU-Arbeitsbereichs. Diese 
Dateien können dann in der Quellcodeansicht bearbeitet werden. 
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Um zur Quellcodeansicht zu gelangen, gehen Sie wie folgt vor: 

1. Klicken Sie die Datei (z. B. main.asm) in den Schaltungswerkzeu-
gen in der Hierarchie der MCU-Arbeitsbereiche doppelt an. 

Die während der Simulation angezeigten zusätzlichen Fehlersuchinforma-
tionen sollen Ihnen einen Einblick in die Vorgänge innerhalb der MCU 
verschaffen. Sie können beispielsweise zwischen dem High-Level-Quell-
code und den Assembler-Anweisungen umschalten, die außerdem den 
tatsächlichen Opcode für jede ausgeführte Anweisung enthalten.  

In der Quellcodeansicht können all diese Zusatzinformationen nicht ange-
zeigt werden. Stattdessen hat jedes MCU-Bauelement im Schaltplan eine 
eigene Debug-Ansicht, in der Angaben zu Fehlern angezeigt werden. 

Um zur Debug-Ansicht zu gelangen, gehen Sie wie folgt vor:

1. Wählen Sie MCU»MCU PIC 16F84A U1»Erstellen. 

Hinweis Die Debug-Ansicht ist nur dann verfügbar, wenn Sie Ihren Code erfolgreich 
erstellt haben, so dass der vorherige Schritt nur einmal notwendig ist. 

2. Wählen Sie MCU»MCU PIC 16F84A U1»Debug-Ansicht.

oder

Klicken Sie im MCU-Arbeitsbereich der Schaltungswerkzeuge einen 
Eintrag mit der rechten Maustaste an und wählen Sie den entsprechen-
den Menüpunkt aus. 
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Im Arbeitsbereich öffnet sich daraufhin eine weitere Registerkarte mit 
dem Namen Debug(<MCU-Referenzbezeichner>), in diesem Fall 
Debug(U1). 

 

Wählen Sie im oberen Teil der Debug-Ansicht zwischen den in Multisim 
erzeugten Disassembler-Anweisungen und der im Assembler/Compiler 
erzeugten Auflistungsdatei aus (das Format der Auflistungsdatei richtet 
sich nach dem Tool, mit dem Sie die Programmdatei erzeugt haben). 

Im Beispiel der LCD-Grafikanzeige wurde der Programmcode in 
Assembler geschrieben und mit Hilfe der Mikrochip-Assembler-Tools in 
eine Programmdatei umgewandelt. Der Mikrochip-Assembler erzeugt eine 
Auflistungsdatei (*.Ist) mit den Opcodes zu jeder Assembler-Anwei-
sung. In der Fehlerlistenansicht werden Informationen aus dieser 
Auflistungsdatei angezeigt. Multisim wandelt die Opcode-Anweisungen 
mit Hilfe eines internen Disassemblers in Assembler-Anweisungen um.  

Für dieses Beispiel ist das Disassembler-Format jedoch nicht notwendig, 
da die Fehlerliste bereits alle erforderlichen Informationen enthält. In den 
Fällen, wo ein MCU-Projekt nur die *.hex-Datei mit dem Maschinencode 
lädt, werden in der Disassembler-Ansicht die aufgeschlüsselten Opcode-
Anweisungen angezeigt. Auf diese Weise wird erkennbar, was innerhalb 
der MCU vor sich geht. Die Disassembler-Ansicht ist sehr nützlich, da für 
MCU-Projekte dieses Typs keine Auflistungsdatei verfügbar ist. 

1  Dropdown-Liste  
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Einfügen von Haltepunkten 
Sie können der Quellcodeansicht sowohl bei angehaltener als auch bei lau-
fender Simulation Haltepunkte hinzufügen. Haltepunkte können einem 
Mikrocontrollerprojekt auf zwei Arten erzeugt werden: 

Eine Möglichkeit besteht darin, die Haltepunkte zur Quellcodeansicht hin-
zuzufügen. Im vorliegenden Beispiel ist die Registerkarte main.asm die 
einzig verfügbare Quellcodeansicht. 

Hinweis Wenn sich Ihr MCU-Entwurf aus mehreren Dateien zusammensetzt, ist für jede 
Ihrer Quellcodedateien eine Quellcodeansicht verfügbar. 

Sie können aber auch einen Haltepunkt in der Debug-Ansicht angeben. Sie 
können Haltepunkte in der Disassembler-Ansicht oder der Fehlerlistenan-
sicht einfügen. In diesem Beispiel benötigen Sie jedoch lediglich die 
Fehlerliste.

 

Um einen Haltepunkt in der Quellcodeansicht hinzuzufügen, gehen Sie wie 
folgt vor: 

1. Öffnen Sie Debug-Ansicht für U1. 

2. Klicken Sie unter Schaltungswerkzeuge doppelt auf main.asm. 

3. Scrollen Sie bis zur Zeile unterhalb der START-Beschriftung: BCF 
STATUS, RP0. 

1  Graue Spalte  
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4. Klicken Sie im Fenster main.asm die erste (graue) Spalte links neben 
BCF STATUS, RP0 doppelt an. Ein roter Punkt an dieser Stelle signa-
lisiert, dass an dieser Zeile ein Haltepunkt gesetzt wurde. 

5. Wählen Sie Simulieren»Start. Die Simulation wird nun automatisch 
an der Stelle unterbrochen, an der Sie den Haltepunkt gesetzt haben. 
Die Debug-Ansicht öffnet sich automatisch und ein gelber Pfeil zeigt 
auf die Stelle, an der die Programmausführung unterbrochen wurde.  

Zum Entfernen des Haltepunkts gehen Sie wie folgt vor: 

1. Klicken Sie einen Haltepunkt in der Debug-Ansicht oder der Quellco-
deansicht main.asm doppelt an. 

oder

Wählen Sie MCU»Alle Haltepunkte entfernen, um alle Haltepunkte 
zu entfernen.  

Hinweis Haltepunkte in der Debug-Ansicht werden genauso hinzugefügt und entfernt 
wie in der Quellcodeansicht. 

Unterbrechen und in/aus Funktionen hinein-/herausspringen 
1. Wählen Sie MCU»Alle Haltepunkte entfernen, um alle Haltepunkte 

zu entfernen. 

2. Wechseln Sie zur Schaltplanansicht (die Registerkarte Getting Star-
ted MCU) und wählen Sie Simulieren»Start. Auf der LCD-Anzeige 
wird nun der Text “Graphical LCD T6963C for Multisim” angezeigt.  

3. Wählen Sie Simulieren»Pausieren.  

4. Rufen Sie die Debug-Ansicht zu U1 auf. Wie Sie sehen, ist die Pro-
grammzeile in der Fehlerliste an der Stelle, an der die Ausführung 
angehalten hat, links durch einen gelben Pfeil gekennzeichnet. 
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5. Wählen Sie MCU»MCU PIC16F84A U1»Speicheransicht, um den 
aktuellen Status des Speichers im Mikrocontroller U1 anzuzeigen. 
Beachten Sie, dass der Wert des Programmzählers PC des IROM-
Abschnitts um eins höher liegt als der Adresswert der Zeile, auf die der 
gelbe Pfeil zeigt. (Im Beispiel in der Abbildung oben hat die Adresse 
in der Debug-Ansicht den Wert 192 und der PC-Wert in der Speicher-
ansicht lautet 193). 

Hinweis Wenn der aktuelle Befehl bei Unterbrechung der Simulation noch nicht vollstän-
dig ausgeführt wurde, bleibt der Wert des Programmzählers der gleiche wie der 
Adresswert. 

Die anderen Abschnitte der Speicheransicht enthalten Werte in ande-
ren Teilen des Mikrocontroller-Speichers. 

6. Klicken Sie in der Symbolleiste Simulation auf die Schaltfläche 
Einzelschritt in den Funktionsaufruf hinein.  

7. Die aktuelle Anweisung wird ausgeführt und die Simulation bei der 
nächsten Anweisung unterbrochen.

8. Wählen Sie Simulieren»Stopp.  
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Unterbrechen und aus Funktion herausspringen 
1. Fügen Sie in die Subroutine SEND_DATA unter MOVWF PORTB einen 

Haltepunkt ein. 

2. Wählen Sie Simulieren»Start. Die Simulation wird am Haltepunkt 
unterbrochen. 

3. Klicken Sie in der Symbolleiste Simulation auf die Schaltfläche 
Aus Funktion herausspringen, um die Subroutine SEND_DATA zu 
verlassen.  

4. Daraufhin werden alle verbleibenden Anweisungen in der Subroutine 
SEND_DATA ausgeführt und die Simulation wird bei der ersten Anwei-
sung nach SEND_DATA unterbrochen. 

Unterbrechen und in Funktion hineinspringen 
1. Wählen Sie MCU»Alle Haltepunkte entfernen.  

2. Setzen Sie vor den Aufruf von SEND_DATA einen Haltpunkt – also 
dort, wo Sie soeben über dem gelben Pfeil herausgesprungen sind. 

3. Wählen Sie Simulieren»Start. Die Simulation wird unterbrochen, wo 
Sie soeben den Haltepunkt gesetzt haben.  

4. Klicken Sie in der Symbolleiste Simulation auf die Schaltfläche 
In Funktion hineinspringen. Die Simulation wird daraufhin in der 
Subroutine SEND_DATA unterbrochen.  

Unterbrechen und Funktionsaufruf überspringen 
1. Wählen Sie Simulieren»Start. Die Simulation wird am selben Halte-

punkt unterbrochen wie zuvor beim Aufruf der Subroutine 
SEND_DATA.  

2. Klicken Sie in der Symbolleiste Simulation auf die Schaltfläche 
Funktionsaufruf überspringen. Die Subroutine SEND_DATA wird 
nun vollständig ausgeführt und die Simulation wird an der ersten 
Anweisung nach CALL_SEND_DATA unterbrochen.  

Zum Cursor 
1. Wählen Sie MCU»Alle Haltepunkte entfernen.  

2. Klicken Sie auf eine Zeile in der SEND_DATA-Subroutine, denn diese 
Subroutine wird bekanntermaßen nochmals aufgerufen, um Daten an 
die LCD-Anzeige zu übermitteln.

3. Klicken Sie in der Werkzeugleiste Simulation auf die Schaltfläche 
Zum Cursor. Die Simulation wird bis zur Anweisung ausgeführt, die 
Sie in der SEND_DATA-Subroutine angeklickt haben. Dann folgt eine 
Ausführungspause und neben die Zeile wird ein gelber Pfeil gesetzt. 
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A
Technische Unterstützung und 
professioneller Service

Auf der Website ni.com/germany finden Sie umfassende Informationen 
über die folgenden professionellen Serviceleistungen und den technischen 
Support von National Instruments:

• Support—Technische Unterstützung erhalten Sie auf der Website 
ni.com/support/d in Form folgender Informationsquellen und 
Tools:

– Technische Ressourcen—Die Website ni.com/support/d 
bietet Ihnen Soforthilfe bei Fragen und Problemen. Außerdem 
finden Sie hier Treiber, Updates, eine umfassende Wissensdaten-
bank (KnowledgeBase), Bedienungsanleitungen, Anleitungen zur 
Problemlösung, Tausende Beispielprogramme, autodidaktische 
Kurse und Application Notes. Registrierte Nutzer können sich 
auch an den Diskussionsforen auf ni.com/forums (englisch) 
beteiligen. Jede im Forum eingereichte Frage wird garantiert 
beantwortet.

– Standard Service Program—Teilnehmer dieses Programms 
können sich telefonisch oder per E-Mail direkt mit unseren 
Applikationsingenieuren in Verbindung setzen und jederzeit die 
Schulungseinheiten im Services Resource Center nutzen. Beim 
Erwerb eines Produkts von National Instruments sind Sie 
automatisch ein Jahr lang zur Teilnahme am Standard Service 
Program berechtigt. Danach ist die Mitgliedschaft kostenpflichtig. 

Welche Art der technischen Unterstützung es in Ihrer Nähe gibt, 
erfahren Sie unter ni.com/services/d oder bei einer unserer 
Niederlassungen (ni.com/contact). 

• Schulung und Zertifizierung—Auf ni.com/training finden Sie 
Lernhandbücher, virtuelle Schulungsräume, Übungs-CDs und Infor-
mationen zu Lernprogrammen mit Abschlusszertifikat. Hier können 
Sie sich auch für eine der weltweit angebotenen Software-Schulungen 
anmelden.
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• Systemintegration—Wenn Sie aus Zeit- oder Personalmangel oder 
anderen Gründen bei der Fertigstellung eines Projekts in Verzug 
geraten, können Ihnen die Mitglieder des NI-Alliance-Programms 
weiterhelfen. Für Informationen zu diesem Programm setzen Sie sich 
entweder telefonisch mit einer National-Instruments-Niederlassung 
in Ihrer Nähe in Verbindung oder besuchen Sie die Website 
ni.com/alliance.

Sollten Sie nach dem Besuch unserer Website ni.com noch Fragen haben, 
wenden Sie sich bitte an eine Niederlassung von National Instruments in 
Ihrer Nähe. Die Telefonnummern unserer Niederlassungen sind am Anfang 
dieses Handbuchs aufgeführt. Auf die Websites der einzelnen Niederlas-
sungen, auf denen Sie immer die aktuellen Kontaktinformationen, 
Telefonnummern des technischen Supports, E-Mail-Adressen sowie aktu-
elle Ereignisse und Veranstaltungen finden, gelangen Sie über 
ni.com/niglobal.
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Stichwortverzeichnis

Zahlen
3D-Schaltungen in Ultiboard, 3-23

A
Analyse, 2-14
Assembler-Programm, 4-4
Aufbau der Benutzeroberfläche, 3-1
automatische Bestückung, 3-19
automatische Leiterbahnführung, 3-20

B
Bauelemente mit zwei Anschlüssen

direkt in eine Verbindung einfügen, 2-9
Beispiele (von National Instruments), A-1
Benutzeroberfläche

Elemente, 2-1
Benutzeroberfläche, Elemente, 2-1
Berichte, 2-17
BOM, 2-18

D
Diagnoseprogramme (von National Instru-

ments), A-1
Dokumentation

in diesem Handbuch verwendete Symbole 
und Darstellungen, v

NI-Informationsquellen, A-1

E
Einfügen von Bauelementen aus der Ulti-

board-Datenbank, 3-11
Einfügen von Bauelementen in Multisim, 2-5
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必ずお読みください

保証
NIのソフトウェア製品が記録されている媒体は、素材および製造技術上の欠陥によるプログラミング上の問題に対して、受領書
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切責任を負いません。

NIは、ここに記載された以外、明示または黙示の保証は致しません。特に、商品性または特定用途への適合性に関する保証は致
しません。NI側の過失または不注意により発生した損害に対するお客様の賠償請求権は、お客様が製品に支払われた金額を上限
とします。NIは、データの消失、利益の損失、製品の使用による損失、付随的または間接的損害に対して、その損害が発生する
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著作権
著作権法に基づき、National Instruments Corporation（米国ナショナルインスツルメンツ社）の書面による事前の許可なく、
本書のすべてまたは一部を写真複写、記録、情報検索システムへの保存、および翻訳を含め、電子的または機械的ないかなる形
式によっても複製または転載することを禁止します。

National Instrumentsは他者の知的財産を尊重しており、お客様も同様の方針に従われますようお願いいたします。NIソフト
ウェアは著作権法その他知的財産権に関する法律により保護されています。NIソフトウェアを用いて他者に帰属するソフトウェ
アその他のマテリアルを複製することは、適用あるライセンスの条件その他の法的規制に従ってそのマテリアルを複製できる場
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BSIM3 and BSIM4 are developed by the Device Research Group of the Department of Electrical Engineering and 
Computer Science, University of California, Berkeley and copyrighted by the University of California. 

The ASM51 cross assembler bundled with Multisim MCU is a copyrighted product of MetaLink Corp. 
(www.metaice.com). 
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disclaimer.
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ち、該当するリソースから参照してください。
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National Instruments Corporation製品を使用する際の警告
(1) National Instruments Corporation（以下「NI」という）の製品は、外科移植またはそれに関連する使用に適した機器の
備わった製品として、または動作不良により人体に深刻な障害を及ぼすおそれのある生命維持装置の重要な機器として設計さ
れておらず、その信頼性があるかどうかの試験も実行されていません。

(2) 上記を含むさまざまな用途において、不適切な要因によってソフトウェア製品の操作の信頼性が損なわれるおそれがありま
す。これには、電力供給の変動、コンピュータハードウェアの誤作動、コンピュータのオペレーティングシステムソフトウェ
アの適合性、アプリケーション開発に使用したコンパイラや開発用ソフトウェアの適合性、インストール時の間違い、ソフト
ウェアとハードウェアの互換性の問題、電子監視・制御機器の誤作動または故障、システム（ハードウェアおよび /またはソフ
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これに限定されません（以下、このような不適切な要因を総称して「システム故障」という）。システム故障が財産または人体
に危害を及ぼす可能性（身体の損傷および死亡の危険を含む）のある用途の場合は、システム故障の危険があるため、1つの形
式のシステムにのみ依存すべきではありません。損害、損傷または死亡といった事態を避けるため、ユーザまたはアプリケー
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ザまたはアプリケーション設計者が、NI製品の適合性を検証、確認する責任を負うものとします。これには、このようなシス
テムまたはアプリケーションの適切な設計、プロセス、安全レベルが含まれますが、これに限定されません。



表記規則

このドキュメントでは以下の表記規則を使用します。

→ 矢印（→）は、ネスト化されたメニュー項目やダイアログボックスのオプ

ションをたどっていくと目的の操作項目を選択できることを示します。

ツール→ ERC マーカをクリア→設計全体の場合、ツールのプルダウンメ

ニューを表示し、ERC マーカをクリア項目を選択して、表示されるダイ

アログボックスから設計全体を選択することを意味します。

このアイコンは、ユーザへのアドバイスを示します。

このアイコンは、注意すべき重要な情報を示します。

太字 太字のテキストは、メニュー項目やダイアログボックスオプションなど、

ソフトウェアでユーザが選択またはクリックする必要がある項目を示しま

す。また、太字のテキストはパラメータ名を示します。

斜体 斜体のテキストは、変数、強調、相互参照、または重要な概念の説明を示

します。また、斜体のテキストは、ユーザが入力する必要がある語句また

は値のプレースホルダも示します。

monospace このフォントのテキストは、キーボードから入力する必要があるテキスト

や文字、コードの一部、プログラムサンプル、構文例を表します。また、

ディスクドライブ、パス、ディレクトリ、プログラム、サブプログラム、

サブルーチンなどの名称、デバイス名、関数、操作、変数、ファイル名お

よび拡張子の引用にも使用されます。
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1
NI Circuit Design Suite の概要

記載されている一部の機能は、NI Circuit Design Suite のバージョンに

よって使用できない場合があります。ご使用のバージョンで利用できる機

能の説明については、『NI Circuit Design Suite リリースノート』を参照

してください。

NI Circuit Design Suite の製品ライン 
ナショナルインスツルメンツの Circuit Design Suite は、EDA

（Electronics Design Automation）ツールのパッケージソフトで、

回路設計フローにおける主なステップを支援します。

Multisim は、回路図の入力、シミュレーション、および PCB レイアウト

のようなダウンステージステップへの準備用に設計された回路図キャプ

チャおよびシミュレーションプログラムです。Multisim には、混合アナ

ログ / デジタルシミュレーション機能、およびマイクロコントローラコシ

ミュレーションも含まれています。

Ultiboard は、プリント回路基板の設計、特定の基本的な機械 CAD 操

作、そして製造の準備に使用します。また、Ultiboard を使用して自動部

品配置およびレイアウトを行うことができます。

チュートリアル 
本書には、以下の段階的なチュートリアルが含まれています。

• 「Multisim チュートリアル」—Multisim およびその多くの機能を紹介

します。

• 「Ultiboard チュートリアル」—Multisim チュートリアルの章で説明

する回路のコンポーネント、そしてトレースを配置する方法を説明し

ます。また、部品を自動配置し、自動で経路設定する方法について習

得します。

• 「Multisim MCU チュートリアル」— マイクロコントローラが含まれ

る回路のシミュレーションおよびデバッグのプロセスを説明します。

これらの章で説明される機能の詳細については、『Multisim Help』また

は『Ultiboard Help』を参照してください。



© National Instruments Corporation 2-1 NI Circuit Design Suite スタートアップガイド

2
Multisim チュートリアル

この章には、Multisim およびその多くの機能を紹介するチュートリアル

が含まれています。

記載されている一部の機能は、NI Circuit Design Suite のバージョンに

よって使用できない場合があります。ご使用のバージョンで利用できる機

能の説明については、『NI Circuit Design Suite リリースノート』を参照

してください。

Multisim インタフェースの概要 
Multisim は、ナショナルインスツルメンツ Circuit Design Suite の回路

図キャプチャおよびシミュレーションアプリケーションであり、EDA
（Electronics Design Automation）ツールのパッケージソフトで、回路

設計フローにおける主なステップを支援します。Multisim は、回路図の

入力、シミュレーション、および PCB レイアウトのようなダウンステー

ジステップへの準備用に設計されています。
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Multisim のユーザインタフェースは、以下の基本要素から構成されてい

ます。
 

メニューバーにすべての機能へのコマンドがあります。

設計ツールボックスでは、プロジェクトの異なるタイプのファイル（回路

図、PCB、レポート）を参照、回路図の階層を表示、そして異なるレイ

ヤーを表示または非表示に設定することができます。

コンポーネントツールバーには、Multisim のデータベースから回路図に

配置するコンポーネントを選択するためのボタンがあります。

1 メニューバー

2 設計ツールボックス

3 コンポーネントツールバー

4 標準ツールバー

5 表示ツールバー

6 シミュレーションツールバー

7 メインツールバー

8 使用中リスト

9 計測器ツールバー

10 左右のスクロール

11 回路ウィンドウ

12 スプレッドシート表示

13 アクティブタブ
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標準ツールバーには、保存、印刷、切り取り、および貼り付けなどの一般

的な操作のボタンがあります。

表示ツールバーには、画面の表示方法を変更するためのボタンがあります。

シミュレーションツールバーには、開始、停止、およびその他のシミュ

レーション機能のボタンがあります。

メインツールバーには、よく使用する Multisim の機能のボタンがあります。

使用中リストには、設計で使用中のすべてのコンポーネントのリストが含

まれています。

計測器ツールバーには、各計測器のボタンがあります。

回路ウィンドウ（またはワークスペース）は、回路設計を行う場所です。

スプレッドシート表示では、フットプリント、参照番号、属性、および設

計制約など、コンポーネントの詳細を含むパラメータの迅速で詳細な表示

および編集が可能です。すべてまたは一部のコンポーネントのパラメータ

を一度に変更したり、さまざまな機能を実行することができます。

概要 
このチュートリアルでは、回路図キャプチャ、シミュレーション、解析と

いった回路設計フローについて説明します。次のページで説明する手順に

従って、小さなアナログ信号をサンプリング、増幅して簡単なデジタルカ

ウンタで信号発生回数をカウントする回路を設計します。

役立つヒントが、左側に以下のようなアイコンによって示されます。

ヒント キーボードで「F1」を押す、またはダイアログボックスのヘルプボタンをク

リックすることで、オンラインヘルプにいつでもアクセスすることができます。

このチュートリアルの配線セクションでは、コンポーネント配置セクショ

ンで作成した回路をそのまま使用することができます。

または、...¥samples¥Getting Started¥にある Getting 
Started 1.ms11を使用することもできます。このファイルでは、
すべてのコンポーネントが正しく配置されています。

シミュレーションセクションでは、作成した回路を使用するか、Getting 
Started 2.ms11（コンポーネントがすべて正しく配線済み）を開きます。
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回路図キャプチャ 
このセクションでは、以下の図のように回路にコンポーネントを配置して

配線します。
 

ファイルを開いて保存する 
以下の手順に従い、Multisim を起動します。

1. スタート→すべてのプログラム→ National Instruments → Circuit 
Design Suite 11.0 → Multisim 11.0 を選択します。「Design1」とい

う空のファイルがワークスペースで開きます。

新しい名前でファイルを保存するには、以下の手順に従います。

1. ファイル→別名で保存を選択して、Windows 標準の保存ダイアログ

を表示します。

2. ファイルを保存する場所へ移動し、MyGettingStartedというファ

イル名を入力して保存ボタンをクリックします。

ヒント データを間違って削除した場合のために、グローバル環境設定ダイアログボッ

クスの保存タブで自動バックアップ作成を設定することができます。
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既存のファイルを開くには、以下の手順に従います。

1. ファイル→開くを選択して、ファイルのある場所へ移動し、ファイル

をハイライトして開くをクリックします。

ヒント Multisim の旧バージョンで保存されたファイルを開くには、開くダイアログ

ボックスのファイルの種類ドロップダウンリストから該当するバージョンを選

択します。

コンポーネントを配置する 
以下の手順に従い、コンポーネントを配置します。

1. 上記の説明に従って MyGettingStarted.ms11を開きます。

2. 配置→コンポーネントを選択してコンポーネントを選択ダイアログ

ボックスを開き、以下の図に示される 7 セグメント LED 表示器を選

択し、OK をクリックします。コンポーネントのゴースト画像がカー

ソル上に表示されます。

ヒント 適切なグループとファミリを選択した後、ブラウザのコンポーネントフィールドに

コンポーネント名を入力します。入力する際、ブラウザの下にある検索中フィール

ドに文字列が表示されます。この例では、「seven_seg_decimal_com_a_blue」
と入力します。入力内容に応じて、一致するコンポーネント名が表示されます。
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3. カーソルをワークスペースの右下へ移動し、左クリックしてコンポー

ネントを配置します。このコンポーネントの参照番号は「U1」とな

ります。

4. 残りのコンポーネントを上の図のようにデジタルカウンタ用の領域に

配置します。
 

メモ 抵抗、インダクタ、コンデンサ（RLC コンポーネント）を配置する場合、コン

ポーネントを選択ダイアログボックスには他のコンポーネントとは若干異なる

フィールドがあります。これらのコンポーネントを配置する際、コンポーネン

ト値（例 : 抵抗値）、タイプ（例 : 炭素膜）、許容差、フットプリント、および製

造元の任意の組み合わせを選択することができます。最終的に PCB レイアウト

にエクスポートされ、材料表の一部になるコンポーネントを配置する場合は、

コンポーネントを選択ダイアログボックスで選択する値の組み合わせが実際に

購入可能なコンポーネントであることに注意する必要があります。

ヒント RLC コンポーネントを配置する場合、コンポーネントリストの上にあるフィー

ルドに配置するデバイス値を入力します。値を表示せずに、回路図に配置する

こともできます。

ヒント 200 Ωの抵抗を配置する場合は、キーボードで「Ctrl-R」を押して、縦になるよ

う回転させます。

ヒント 各コンポーネントの参照番号（例 : U1、U2 など）は、配置した順番に割り当て

られます。従って、コンポーネントを配置する順番によっては、上の図と参照

番号が異なる場合があります。これは、回路の動作には影響しません。
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5. カウンタ制御用の領域に部品を配置します。配置が完了したら、各

SPDT スイッチを右クリックして左右反転を選択します。
 

ヒント SPDT スイッチは、Basic グループの SWITCH ファミリにあります。

ヒント すでにワークスペースに配置したコンポーネントと同じコンポーネントを再度

配置するには、配置済みのコンポーネントをハイライト表示して編集→コピー

を選択し、編集→貼り付けを選択します。また、使用中リストから選択して、

クリックしてワークスペースに配置することもできます。

6. 下の図のように、アナログ増幅用の領域にコンポーネントを配置しま

す。部品は必要に応じて回転させます。
 

AC 電圧信号ソースを配置したら、その上でダブルクリックします。

電圧（Pk）を 0.2 V に変更し、OK をクリックしてダイアログボック

スを閉じます。
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7. 下の図のように、バイパスコンデンサ用の領域にコンポーネントを配

置します。
 

8. 下の図に示されるように、ヘッダと関連コンポーネントを配置しま

す。
 

ヒント J3 は、Basic グループの CONNECTORS ファミリにあります。

ヒント 回路の配線が完了したら、抵抗などの 2 ピンコンポーネントを直接ワイヤにド

ロップすることができます。接続は Multisim によって自動的に接続されます。
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回路を配線する 
すべてのコンポーネントには、他のコンポーネントまたは計測器に配線す

るためのピンがあります。カーソルをピンの上に配置すると十字に変化

し、Multisim で配線を開始できるようになります。

ヒント ワークスペースに配置した回路を配線するか、Getting Startedフォルダ

（samplesフォルダ内）から Getting Started 1.ms11を使用することもでき

ます。

以下の手順に従い、回路を配線します。

1. コンポーネントのピンをクリックして接続を開始し（ポイントが十字

に変化します）、マウスを移動させます。カーソルの動きに合わせて

ワイヤが表示されます。

2. 2 番目のコンポーネントのピンをクリックして接続を完了します。以

下に示されるように、Multisim は適切な構成にワイヤを自動的に配

置します。この機能により、大規模な回路を配線する場合に大幅に時

間を節約することができます。
 

ヒント 配線中にマウスをクリックして、ワイヤの位置を指定することもできます。マ

ウスをクリックするたびに、ワイヤがそのポイントに固定されます。
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3. 下の図に示されるように、デジタルカウンタ領域のコンポーネントを

配線します。
 

ヒント U3 や R4 などのマルチピンデバイスをバスで接続するには、バスベクトル接続

を使用します。詳細については、『Multisim Help』を参照してください。

ヒント 仮想配線 - カウンタ制御領域とデジタルカウンタ領域の間の接続では、仮想接続

を使用して配線を簡潔にすることができます。同じネット名の 2 つの回路は、

仮想接続することができます。
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4. 下の図のように配線を完了します。
 

シミュレーション 
回路を Multisim でシミュレートすると、設計フローの早い段階でエラー

を検出することができ、時間とコストを削減することができます。

仮想計測器 
このセクションでは、仮想オシロスコープを使用する回路のシミュレー

ションを行います。

ヒント Getting Startedフォルダ（samplesフォルダ内）から Getting 
Started 2.ms11を使用することもできます。

1. J1、J2、R2 は対話式コンポーネントです。

各コンポーネントをダブルクリックし、値タブでキーを選択して、

J1、J2、および R2 の操作キーを設定します。J1、J2、R2 のキー

フィールドにそれぞれ「E」、「L」、「A」と入力します。

2. キーボードの「E」を押してカウンタを有効にするか、カーソルを

「J1」の上に移動すると表示されるスイッチアームをクリックしま

す。
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3. シミュレート→計測器→オシロスコープを選択して、ワークスペース

にオシロスコープを配置します。手順 5 で示されるように計測器を

配線します。

ヒント オシロスコープのトレースを簡単に区別するには、スコープの「B」入力に配線

されているワイヤを右クリックし、表示される詳細メニューからセグメントカ

ラーを選択します。たとえば青など、「A」入力に接続されているワイヤと異な

る色を選択します。（ワイヤの色の変更やその他の編集機能は、シミュレーショ

ンの実行中に実行できません）。

4. スコープのアイコンをダブルクリックして計測器を表示します。シ

ミュレート→実行を選択します。オペアンプの出力がスコープに表示

されます。 

5. タイムベースを 2 ms/Div に変更して、チャンネル A のスケールを

500 mV/Div に設定します。次のようにスコープに表示されます。
 

回路のシミュレーション実行中に、7 セグメントのカウンタの数値が

増加し、各カウントサイクルの終りに LED が点滅します。

6. シミュレーション実行中にキーボードの「E」キーを押して、カウン

タを有効 / 無効に切り替えます。有効はアクティブ LOW です。

「L」キーを押してカウンタにゼロをロードします。ロードはアクティ

ブ LOW です。

「Shift-A」キーを押して、ポテンショメータの設定値の減分を確認し

ます。「A」キーを押して設定値を増分し、同じ操作を繰り返します。
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ヒント 上記のキーを押す代わりに、マウスで回路図上の対話式コンポーネントを直接

操作することができます。

解析 
このセクションでは、AC 解析を用いてアンプの周波数応答を検証しま

す。

オペアンプの出力で AC 解析を実行するには、以下の手順に従います。

1. オペアンプのピン 6 に接続されているワイヤの上でダブルクリック

し、ネット設定ダイアログボックスでネット名を「analog_out」に

変更します。

2. シミュレート→解析→ AC 解析を選択して、出力タブをクリックし

ます。
 

3. 左の列の V(analog_out)をハイライトし、追加をクリックします。

V(analog_out)が右の列に移動します。これにより、ノードの電圧

V(analog_out)が表示されます。
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4. シミュレーションをクリックします。解析結果がグラファに表示され

ます。
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グラファ 
グラファは、グラフや表を表示、調整、保存、エクスポートするための多

目的表示ツールです。Multisim によるすべての解析結果のグラフや表、

または一部の計測器のトレースのグラフを表示するために使用します

（例 : オシロスコープの結果）。

グラファ上にシミュレーションの結果を表示するには、以下の手順に従い

ます。

1. 上記の説明に従って、シミュレーションを実行します。

2. 表示→グラファを選択します。

後処理 
後処理では、回路で実行された解析の出力を編集し、結果をグラフまたは

チャートにプロットすることができます。解析結果で実行できる数学演算

の種類は、算術演算、三角関数、指数関数、対数関数、複素演算、ベクト

ル演算、および論理演算です。
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レポート 
Multisim では、材料表（BOM）、コンポーネント詳細レポート、ネット

リストレポート、回路図統計、スペアゲート、および相互参照レポートな

どの多くのレポートを生成できます。このセクションでは、チュートリア

ルの回路の例として BOM を使用します。

材料表 
材料表は、設計で使用されるコンポーネントの一覧で、回路基板の製造に

必要なコンポーネントの概要を示します。提供される情報には、以下が含

まれます。

• 必要な各コンポーネントの数量。

• 詳細 : コンポーネントのタイプ（例 : 抵抗）および値（例 : 5.1 kΩ) を
含む。

• 各コンポーネントの参照番号。

• 各コンポーネントのパッケージまたはフットプリント。

回路の BOM（材料表）を作成するには、以下の手順に従います。

1. レポート→材料表を選択します。

以下のようなレポートが表示されます。
 

材料表を印刷するには、印刷ボタンをクリックします。Windows 標準の

印刷ダイアログボックスが表示され、プリンタ、コピー数などを選択でき

ます。 
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材料表をファイルに保存するには、保存ボタンをクリックします。

Windows 標準のファイル保存ダイアログボックスが表示され、パスと

ファイル名を指定することができます。 

材料表は主に調達および製造プロセスの支援が目的であるため、実際のコ

ンポーネントのみが含まれています。ソースや仮想コンポーネントなどの

実物ではない、または購入不可能なコンポーネントは除外されます。フッ

トプリントに割り当てられていないコンポーネントは、材料表に表示され

ません。

回路の実際のコンポーネントではないコンポーネントの一覧を表示するに

は、仮想ボタンをクリックします。別のウィンドウにこれらのコンポーネ

ントのみを表示します。 

この詳細情報および他のレポートについては、『Multisim Help』を参照

してください。



© National Instruments Corporation 3-1 NI Circuit Design Suite スタートアップガイド

3
Ultiboard チュートリアル

この章のチュートリアルでは、Multisim チュートリアルの章に記載され

る回路の部品およびトレースを配置する方法を説明します。

ヒント Multisim から Ultiboard に設計をエクスポートする方法については、『Multisim 
Help』および『Ultiboard Help』を参照してください。

記載されている一部の機能は、Ultiboard のバージョンによって使用でき

ない場合があります。ご使用のバージョンで利用できる機能の説明につい

ては、『NI Circuit Design Suite リリースノート』を参照してください。

Ultiboard インタフェースの概要 
Ultiboard は、ナショナルインスツルメンツ Circuit Design Suite の

PCB レイアウトアプリケーションであり、EDA（Electronics Design 
Automation）ツールのパッケージソフトで、回路設計フローにおける主

なステップを支援します。

Ultiboard は、プリント回路基板のレイアウトおよび経路設定、特定の基

本的な機械 CAD 操作の実行、そして製造の準備に使用します。また、

Ultiboard を使用して自動部品配置およびレイアウトを行うことができま

す。
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Ultiboard のユーザインタフェースは、複数の要素から構成されていま

す。
 

メニューバーにすべての機能へのコマンドがあります。

標準ツールバーには、保存、印刷、切り取り、および貼り付けなどの一般

的な操作のボタンがあります。

1 メニューバー

2 標準ツールバー

3 選択ツールバー

4 描画設定ツールバー

5 表示ツールバー

6 メインツールバー

7 自動経路設定ツールバー

8 ステータスバー

9 ワークスペース

10 スプレッドシート表示

11 設計ツールボックス

12 3D プレビュー

13 全体図ビュー
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より多くの部品およびトレースをボードに追加すると、それらの中から使

用するものだけを選択することが難しくなります。選択ツールバーには、

選択の制御に使用するボタンが含まれています。

描画設定ツールバーでは、描画するラインまたはオブジェクトの太さおよ

び測定単位、そしてレイヤーを選択することができます。このツールバー

にはまた、ラインの外観、そしてレイヤーに描画する形状を制御する機能

のボタンが含まれています。

表示ツールバーには、画面の表示方法を変更するためのボタンがあります。

メインツールバーには、よく使用するボード設計機能のボタンがあります。

自動経路設定ツールバーには、自動経路設定および部品配置機能がありま

す。

ステータスバーは、役立つ重要情報を表示します。

ワークスペースでは、設計を行います。

スプレッドシート表示では、フットプリント、形状、参照番号、属性、お

よび設計制約など、部品の詳細を含むパラメータの迅速で詳細な表示およ

び編集が可能です。

設計ツールボックスでは、設計の要素を表示、非表示、または淡色表示に

設定することができます。

3D プレビューでは、ボードの 3 次元プレビューを表示することができま

す。

全体図ビューは設計の全体図を表示し、ワークスペースでの操作を簡単に

します。

チュートリアルを開く 
チュートリアルファイルを開くには、以下の手順に従います。

1. スタート→すべてのプログラム→ National Instruments → Circuit 
Design Suite 11.0 → Ultiboard 11.0 を選択して、Ultiboard を起動

します。

2. ファイル→サンプルを開くを選択し、Getting Startedフォルダを

ダブルクリックして開きます。
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3. Getting Started.ewprjを選択して、開くをクリックします。プ

ロジェクトファイルが Ultiboard にロードされます。

4. プロジェクトから設計（例 : GS1）を選択するには、そのタブをク

リックするか、設計ツールボックスのプロジェクトタブ内の名前をク

リックします。

ボードアウトラインを作成する 
ボードアウトラインは既に存在しますが、この設計の部品に適したサイズ

のボードアウトラインを以下のいずれかの方法で作成することができま

す。

• 描画ツールを使用してボードアウトラインを描画。

• DXF ファイルをインポート。

• ボードウィザードを使用。
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以下の手順に従い、ボードウィザードを使用します。

1. レイヤータブでボードアウトラインをダブルクリックして、レイヤー

をアクティブにします。

2. GS1設計で既存のボードアウトラインをクリックして、キーボードで

「Delete」を押します。

3. ツール→ボードウィザードを選択します。
 

4. レイヤーテクノロジを変更オプションを有効にして、他のオプション

が利用できるようにします。

5. 両面ボード（レイヤーペア）とシングルレイヤースタックアップで構

築されたマルチレイヤーを選択して、次へをクリックします。
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6. 次のダイアログボックスで、ボードのラミネート設定を定義します。

（このチュートリアルでは設定は変更しません）。
 

7. 次へをクリックします。

ボードウィザード - ボードの形状ダイアログボックスでは、以下に注

意してください。

• 基準ポイントがアライメントで下（左）に設定されている。

• 長方形オプションが選択されている。

• 幅を 3000、高さを 2000 に設定する（この設計の部品に最適な

サイズ）。

• 間隔を 5.00000 に設定する。これは要素を配置しない、ボード

の端からの距離です。

8. 終了をクリックします。ボードアウトラインは設計に配置されます。

メモ ボードウィザードの詳細については、『Ultiboard Help』を参照してください。
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以下の手順に従い、ボードアウトラインを移動します。

1. レイヤータブのボードアウトラインをダブルクリックします。

2. ワークスペースのボードラインをクリックして、ボードを部品の行の

すぐ下にドラッグします。

以下の手順に従い、基準ポイントを変更します。

1. 設計→基準ポイントを設定を選択します。カーソルに基準ポイントが

表示されます。

2. カーソルをボードラインの左下へ移動し、クリックして配置します。
 

部品を配置する 
GS1設計ファイルにさまざまな方法で部品を配置することができます。

• ボードアウトラインの外側から 1 つまたは複数の部品を選択して所

定の位置へドラッグする。

• スプレッドシート表示の部品タブを使用して部品を検索して配置す

る。

• データベースから部品を選択する。

ヒント 配置→部品配置を取り消しコマンドを使用して、ロックされていないすべての

部品を PCB から素早く削除して、異なる配置方法を試すことができます。
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ボードアウトラインの外側から部品をドラッグする 
デフォルトでは、Multisim または他の回路図キャプチャプログラムから

のネットリストを開くと、コンポーネントはボードアウトラインの外側に

配置されています。

始める前に、設計ツールボックスで銅（上）レイヤーをダブルクリックし

て、アクティブレイヤーにします。

以下の手順に従い、U1 をボードアウトラインの外側にドラッグします。

1. ボードアウトラインの外側の部品のコレクションの中から U1 を探しま

す。U1 が見えるまでズームインする（「F8」を押す）ことができます。

ヒント また、編集→検索コマンドで部品を検索することもできます。このコマンドは

他のアプリケーションの検索機能のような役割を果たし、名前、番号、形状、

値、またはすべての変数から検索することができます。詳細については、

『Ultiboard Help』を参照してください。

2. U1（7 セグメント表示器）をクリックして、下記の図に表示される

位置にドラッグします。
 

U1 は選択されたままです。これは、アプリケーションにおける

Ultiboard の重要な点であり、すべての操作を明示的に終了する必要

1 フォースベクトル 2 ラッツネスト
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があります。この場合、他の場所をクリックして部品を選択解除しま

す。また、右クリックすると現在の操作が終了します。

3. スプレッドシート表示の部品タブへ移動し、U1 が表示されるまでスク

ロールします。部品の隣の緑のライトがやや明るくなっていることに

注意してください。これは、部品が配置されたことを示しています。

部品タブから部品をドラッグする 
以下の手順に従い、部品を部品タブからドラッグします。

1. 部品タブで J3 が表示されるまでスクロールします。
 

2. J3 をクリックして、部品タブからワークスペースにドラッグします。

ポインタの動きに合わせて J3 が表示されます。

3. J3 をボードの左側のエッジの、やや中央にドロップします。上記の

ように、部品タブの J3 の緑色のライトはやや明るくなり、部品が配

置されたことを示しています。
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チュートリアルの部品を配置する 
任意の方法、また任意の方法の組み合わせで、以下の図のようなレイアウ

トを作成してください。すでにこのように配置されている、プロジェクト

の次の設計ファイル、GS2を使用することもできます。

設計は以下のようになります。
 

データベースから部品を配置する 
設計ファイルにインポートされた部品を配置する以外に、データベースか

ら直接部品を配置することができます。以下では、この方法を使用して取

り付け穴を配置します。

以下の手順に従い、データベースから部品を配置します。

1. 配置→データベースからを選択します。データベースから部品を取得

ダイアログボックスが表示されます。 

2. データベースパネルで、スルーホールテクノロジカテゴリを展開し、

穴カテゴリを参照します。使用可能な部品パネルに部品が表示されま

す。
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3. 使用可能な部品パネルで、HOLE35 を選択します。プレビューパネル

に部品が表示されます。
 

4. OK をクリックします。データベースから部品を取得ダイアログボッ

クスが消え、参照番号および値を入力するダイアログボックスが表示

されます。

5. 穴の参照番号（H1）および値（HOLE）を入力して、OK をクリック

します。

6. ボード上にポインタを移動します。ポインタに部品が表示されます。

7. 左上隅の位置に穴を移動したら、クリックしてボードにドロップしま

す。

8. 参照番号が自動的に H2 に増分された部品の参照番号を入力ダイアロ

グボックスが再び表示されます。

9. 値（HOLE）を入力して OK をクリックし、次の取り付け穴を右上隅

に配置し、同じ作業を繰り返して H3 を右下隅に配置し、H4 を左下

隅に配置します。

10. キャンセルをクリックして停止し、キャンセルをもう一度クリックし

てデータベースから部品を取得ダイアログボックスを閉じます。
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部品を移動する 
配置する方法と同じ方法で部品を移動することができます。クリックする

だけで、ボード上に既にある部品を選択できます。選択した部品の移動先

の X/Y 座標を指定するには、数値キーパッドの「*」キーを押します。ま

た、部品タブで配置した部品（隣に緑色のライトで示される）を選択し、

新しい場所にドラッグします。

ヒント 部品のラベルは、形状とは別の要素です。ボードで部品を選択する場合は、ラ

ベルだけでなく部品全体を選択してください。選択フィルタの使用を試みてく

ださい。詳細については、『Ultiboard Help』を参照してください。

ヒント 部品を選択したら、キーボードの矢印キーを押して、ボード上で移動すること

もできます。

また、部品のグループを選択して、同時に移動することもできます。これ

を行うには、以下のうちの 1 つを実行してください。

• 「Shift」キーを押したまま、複数の部品をクリックする。

• いくつかの部品の周りをマウスでドラッグしてボックスで囲む。

選択されたすべての部品は、カーソルをドラッグすると移動します。
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ヒント これらは一時的なグループで、他の部品を選択するとグループ接続は解除され

ます。グループが削除するまで残るようにするには、グループエディタを使用

します。詳細については、『Ultiboard Help』を参照してください。

部品を移動するもう 1 つの方法は、編集→整列コマンドを使用して、選

択した部品の端を揃えるか、部品間のスペースを相対的に設定します。

編集→整列コマンドを使用して、配置した取り付け穴を揃えます。

1. H1 を選択して、「Shift」キーを押したまま H2 を選択します。

2. 編集→整列→上揃えを選択します。H2 が H1 に沿って配置されてい

なかった場合は、H2 が移動します。

3. ボード上の空白をクリックして、H2 と H3 を選択します。

4. 編集→整列→右揃えを選択します。

5. 同様に H3 と H4 の下端、および H1 と H4 の左端を揃えます。

トレースを配置する 
トレースの配置には以下のオプションがあります。

• 手動トレース。

• 誘導型トレース。

• 接続マシントレース。

手動トレースは、ユーザの設定に従って、コンポーネントまたはトレース

を介する場合も指定した通りに配置されます。誘導型トレースは、マウス

操作で選択したピン間に有効なトレースを自動的に描画します。ピンから

ピンへ移動することで、有効なトレースを作成することができます。接続

マシントレースは、最も効率の良い経路で 2 つのピンを自動的に接合し

ます。オプションで経路を変更することもできます。

トレースを配置する際は、最後にクリックして固定する前に解除すること

によってセグメントを削除することができます。手動トレースを配置中に

クリック、もしくは誘導型トレースまたは接続マシントレースで方向を変

更するたびに、トレースの個別のセグメントが作成されます。トレースの

操作をする場合、最適なセグメントを選択するか、必要であればトレース

全体を選択します。
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手動トレースを配置する 
今まで作業してきた設計を継続して使用するか、GS3を使用します。開

始する前に銅（上）レイヤーが選択されていることを確認してください。

銅（上）が設計ツールボックスのレイヤータブで赤でハイライトされま

す。

ヒント 必要な場合は、「F7」を押して設計全体を表示します。

以下の手順に従い、トレースを手動で配置します。

1. 配置→ラインを選択します。

ヒント ラインコマンドは任意のレイヤー上にラインを作成するために使用します。結

果は、選択するレイヤーによって異なります。たとえば、選択したレイヤーが

シルクスクリーンの場合、PCB のシルクスクリーンレイヤー上にラインを作成

します。選択したレイヤーが銅の場合、ラインが実際のトレースになります。

2. ボードの左側にある J3 を検索します。下記に示される開始ピンを検

索します。
 

ヒント フォースベクトルを無効にするか淡色表示すると、ネットをより明確に表示で

きます。設計ツールボックスのレイヤータブのフォースベクトルチェックボッ

クスを使用して表示を変更します。フォースベクトルについては、『Ultiboard 
Help』を参照してください。

1 部品 J3 2 開始ピン
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ヒント 部品を検索できない場合は、部品タブの検索機能を使用します。部品タブで部

品を選択して、部品を検索して選択ボタンをクリックします。部品は、ワーク

スペースに表示されます。必要な場合は、「F8」を使用してさらにズームインし

ます。

3. 上記のステップで指定されたピンをクリックします。Ultiboard は、

クリックしたピンと同じネット上のすべてのピンを X 印でハイライ

トします。（ハイライトに使用される色は、グローバル環境設定ダイ

アログボックスのカラータブで変更できます）。この方法で、回路図

の接続と一致するピンの接続先を探すことができます。
 

4. カーソルを動かします。緑のライン（トレース）は選択されたピンに

固定されます。クリックするたびに、以下の図（2）のようにトレー

スセグメントが固定されます。

1  同じネットのピン  
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5. 配線先のピンをクリックします。
 

6. 右クリックして、トレースの配置を終了します。

7. ライン配置モードを終了するには、メインツールバーの選択ボタンを

クリックします。 

誘導型トレースを配置する 
以下の手順に従い、誘導型トレースを配置します。

1. 配置→誘導型を選択します。 

2. J3 の一番上のピンをクリックします。

3. U4 の左列の下から 2 番目のピンをクリックします。

4. Ultiboard が自動的に接続を描画します。

ヒント ピンをクリックする必要はありません。ラッツネストラインをクリックして開

始することもできます。

1 トレース

2 クリックしてトレースを固定
3 配線先のピン
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接続マシントレースを配置する 
以下の手順に従い、接続マシントレースを配置します。

1. 配置→接続マシンを選択します。 

2. 下記に示されるラッツネストのセグメントをクリックします。
 

3. カーソルを動かします。Ultiboard は、障害物の周りを経路設定する

さまざまなトレース配置オプションを表示します。

1 ラッツネストをクリック  
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4. 設定したい経路がある場合、クリックしてトレースを固定します。

ラッツネストまたは配線先のピンをクリックする必要はありません。
 

5. 右クリックしてトレース配置を終了します。

自動部品配置 
この章で説明された部品の配置以外に、Ultiboard の上級自動部品配置機

能を使用することができます。

ヒント 部品を自動配置する前に、自動配置プロセス中に移動しない部品すべてをあら

かじめ配置してロックします。（GS5の取り付け穴および U1、J1、J2、J3、
LED はあらかじめ配置されロックされています）。部品をロックする方法の詳細

については、『Ultiboard Help』を参照してください。

1 ピンの間に表示されるトレースセグメント  
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Getting Started.ewprjで部品を自動配置するには、以下の手順に従

います。

1. Ultiboard で GS5設計を開きます。

2. 自動経路設定→自動配置を開始を選択します。部品が回路基板に配置

されます。
 

トレースを自動経路設定する 
この章ですでに説明した方法、または以下で説明する自動的に経路設定す

る方法で、Ultiboard にトレースを配置することができます。

Getting Started.ewprjでトレースを自動設定するには、以下の手順

に従います。

1. Ultiboard で GS3設計を開きます。

2. 自動経路設定→自動経路設定を開始 / 再開を選択します。ワークス

ペースは自動経路設定モードになり、トレースの自動経路設定が開始

されます。

自動経路設定が開始されると、トレースがボードに配置されます。自

動経路設定が完了すると、自動経路設定モードが閉じ、ワークスペー

スに戻ります。

3. オプションで、自動経路設定→最適化を開始を選択して、トレースの

配置を最適化することができます。
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自動経路設定は、いつでも終了することができ、手動で変更できます。自

動経路設定を再開すると、変更を反映して継続します。手動で配置したト

レースで、自動経路設定機能によって移動したくないトレースはロックし

てください。

ヒント 経路設定オプションダイアログボックスを使用して、自動配置および自動経路

設定オプションを変更できます。詳細については、『Ultiboard Help』を参照し

てください。

製造 / アセンブリの準備をする 
Ultiboard は、多くの異なる出力フォーマットが生成可能で、生産および

製造のニーズに対応します。このセクションでは、生産およびドキュメン

ト化のためにボードを出力する機能について説明します。

ボードをクリーンアップする 
ボードの製造に進む前に、開いているトレース終端（設計で終端接続がさ

れていないトレースセグメント）、ボードに残っている未使用のビアを削

除する必要があります。

開いているトレース終端を削除するには、GS4設計が開いていることを確

認して、編集→銅を削除→開いたトーレス終端を選択します。この方法で

は、設計中のすべての開いているトレースが削除されます。
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未使用のビアを削除するには、設計が開いていることを確認し、設計→未

使用ビアを削除を選択して、トレースセグメントまたは接続されている銅

領域を持たないすべてのビアを削除します。

コメントを追加する 
コメントを使用して設計の変更指示を表示したり、チームメンバー間の共

同作業を容易にしたり、背景情報を設計に追加することができます。

コメントをワークスペースや部品に固定することができます。コメントの

付いた部品が移動されると、コメントも一緒に移動します。

詳細については、『Ultiboard Help』を参照してください。

ファイルをエクスポートする 
エクスポートされたファイルには、完成ボードの製造方法の詳細情報が含

まれています。エクスポートできるファイルには、Gerber RS-274X およ

び RS-274D ファイルが含まれます。

詳細については、『Ultiboard Help』を参照してください。

設計を 3D で表示する 
Ultiboard では、設計中にいつでも 3 次元でボードを表示できます。詳細

については、『Ultiboard Help』を参照してください。
 

ヒント 内部ビューを使用して、マルチレイヤー PCB のレイヤー間を表示することがで

きます。詳細については、『Ultiboard Help』を参照してください。
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4
Multisim MCU チュートリアル

この章のチュートリアルでは、マイクロコントローラが含まれる回路のシ

ミュレーションおよびデバッグのプロセスを説明します。

記載されている一部の機能は、NI Circuit Design Suite のバージョンに

よって使用できない場合があります。ご使用のバージョンで使用できる機

能の説明については、『NI Circuit Design Suite リリースノート』を参照

してください。

概要 
このチュートリアルで使用されるファイルは、NI Circuit Design Suite ソ

フトウェアと一緒に ...¥samples¥Getting Startedにインストールさ

れます。

このチュートリアルでは、Getting Started MCU.ms11を使用し、

LCDWorkspaceのフォルダへのアクセスが必要です。

液晶グラフィックディスプレイ（LDC）回路の例は、Toshiba T6963C コ

ントローラおよび外部表示 RAM を組み合わせて、Multisim におけるグ

ラフィック LCD を制御する PIC マイクロコントローラの使用方法を示し

ます。LCD を制御する際、マイクロコントローラは LCD のデータおよび

制御ラインを介して LCD に信号を送信します。マイクロコントローラ用

に書かれたソフトウェアプログラムが、LCD にコマンドおよびデータを

送信するためにピンのラインを HIGH または LOW に設定する論理を決定

します。
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チュートリアルについて 
LCD U2 のデータラインは、マイクロコントローラ U1 のピン RB0 ～ RB7
に接続されています。LCD の制御ラインは、マイクロコントローラの

RA0 ～ RA2 に接続されます。MCU U1 は、これらのワイヤを通じて

LCD U2 と通信します。データが並行して U2 に送信され、制御ラインの

信号が送信されるデータのタイミングとタイプ（アドレスまたはデータ）

を決定します。

LCD は、テキストモード、グラフィックモード、およびテキスト / グラ

フィックの混合モードの、3 モードで操作することができます。この例

は、テキスト / グラフィック混合モードでの LCD の制御です。MCU が

実行するソフトウェアは、LCDWorkspaceという名前で設計ツールボッ

クス内の MCU ワークスペースに表示されます。ワークスペースには、シ

ングルソースコードファイル main.asmから構成される 1 つのプロジェ

クト project1が含まれています。
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以下の手順に従って、ファイルを表示します。

1. 設計ツールボックスで main.asmをダブルクリックします。回路図

キャプチャワークスペースに main.asmという名前のタブが現れ、

アセンブリプログラムが表示されます。
 

ライン番号を表示するには、MCU →ライン番号を表示を選択します。

以下の手順に従って、この回路を実行します。

1. シミュレート→実行を選択します。あからじめプログラムをプログラ

ムをビルドしていない場合は、ダイアログボックスに構成が古いこと

が示され、ビルドするかどうかを確認するメッセージが表示されま

す。はいをクリックします。ビルドの結果がスプレッドシートビュー

の結果タブに表示されます。 

設計タブに切り替えます。プログラムはテキストモードで

「Graphical LCD T6963C for Multisim」の文字を表示し、LCD がグ

ラフィックモードに切り替わり、反転した「V」がドット単位でテキ

スト上に描画されます。

ラインが描画されると、テキストは右、そして左にスクロールされま

す。これは、LCD のテキストバッファの開始アドレスを移動するこ

とによって実行できます。また、LCD にはバッファが 2 つあり、1
つはグラフィックの格納、もう 1 つはテキストの格納用であること

も示しています。テキスト点滅および文字消去などの LCD のその他

の機能も示されています。

LCD プログラムは、これらの各効果を継続して繰り返します。

シミュレーションを停止するには、シミュレート→停止を選択します。 
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アセンブリプログラムを理解する 
定数およびデータ

main.asmに戻ります。

プログラムを簡単するために、LCD ディスプレイコマンドおよびアドレ

スとデータを MCU に一時保存するバッファがプログラムの最初に定数で

定義されています。
 

LCD に表示されるテキストがデータ表に格納されているマイクロコント

ローラもありますが、プログラムメモリスペースのデータ値を直接指定で

きる PIC アセンブリ命令はありません。代わりに、文字データ値を W レ

ジスタにロードすれば、指標に基づいて文字列の中から値を返すルーチン

を使用することができます。RETLW命令は、1 回の命令で定数値を W レ

ジスタにロードし、RETURNを実行します。

TXPRTルーチンは、LCD に表示するテキストデータを取得します。LCD
の文字モードは、T6963C コントローラのリファレンスマニュアルに定義

されています（例 : 0x27は「G」、0x52は「r」のコードなど）。
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初期化

初期コードは、以下の引用に示される通り、STARTラベルから開始しま

す。マイクロコントローラのピンは出力ピンとして設定され、値はリセッ

トされます。LCD コンポーネントは、マイクロコントローラによって初

期化され、グラフィック / テキストモードに設定されます。LCD コン

ポーネントの内部のグラフィックとテキストバッファのホームアドレス

は、0x0000および 0x2941にそれぞれ設定されます。これにより、LCD
がディスプレイ上でバッファデータの表示を開始する場所を指定します。

最後に、制御信号が LCD 上の適切な読み取り / 書き込み操作用に設定さ

れます。
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テキストおよびグラフィックを描画する

残りのプログラムは、LCD に MCU ピン RA0 ～ RA2 の制御ラインを介

してコマンドを送信し、データラインを介してデータを送信します。
 

たとえば、プログラム内のメインループからの上記の引用は、TXPRTサ

ブルーチンで定義された文字を送信して、LCD にテキストモードで表示

します。

以下は LCD を自動書き込みモードに設定します。

MOVLW CMD_AWRON
MOVWF CMD_BUFFER
CALL CMD

この時点でプログラムはカウントを開始し、ループ LOOP_READ_DATA2
を 35 回実行します。このループは、TXPRTを呼び出し、テキストデータ

を取得して W レジスタにロードします。そして、サブルーチン ADTを呼
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び出します。ADT はさらに、W レジスタ値をポート B に書き込み、LCD
のデータラインに送信する SEND_DATAを呼び出します。データが送信さ

れると、マイクロコントローラのポート A 上の適切な値が LCD の制御ピ

ンに送信され、データの読み取り準備ができたことを知らせます。サブ

ルーチンが最後まで実行されると、そのサブルーチンの呼び出し直後の命

令ラインへ返り、35 文字がすべて転送されるまで同じ動作を繰り返しま

す。引用の最後の 3 つの命令が、ループを出た後に LCD の自動書き込み

モードを OFF にします。

MOVLW CMD_AWROFF
MOVWF CMD_BUFFER
CALL CMD

以下の命令は、グラフィックモードで水平および直線ラインを描画します。

;6 draw wave once
MOVF ADDR_L, 0
BTFSC STATUS, Z
CALL DRAW_WAVE

MCU デバッグ機能を使用する 
このセクションでは、段階的に Multisim MCU モジュールのデバッグ機

能について説明します。以下の説明どおりに作業を行わない場合、これら

の説明が該当しなくなります。ブレークポイントとシングルステップ機能

を理解したら、上級 MCU デバッグ機能を試してください。

デバッグ表示の概要 
C またはアセンブリのいずれかでマイクロコントローラのプログラムを

書くには、ソースコードファイル（.asm、.inc、.c、.h）を MCU ワー

クスペースで作成して、ソースコードビューで編集します。

ソースコードビューにアクセスするには、以下の手順に従います。

1. 設計ツールボックスの MCU ワークスペース階層に表示されるファイ

ル項目（例 : main.asm）をダブルクリックします。

シミュレーション中に表示される追加デバッグ情報は、MCU 内で起こっ

ている状況を理解する上で役立ちます。たとえば、発生するイベントの表

示を、ハイレベルソースレベルとアセンブリ命令レベル間で切り替えるこ

とができます。アセンブリ命令レベルでは、各命令に対して MCU が実行

する操作コードも表示します。
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ソースコードビューは、この追加情報すべてを表示することができませ

ん。代わりに、回路設計の MCU コンポーネントには、デバッグ情報を表

示するための専用のデバッグ表示があります。

デバッグ表示にアクセスするには、以下の手順に従います。

1. MCU → MCU PIC 16F84A U1 →ビルドを選択します。

メモ デバッグ表示はコードのビルドが完了すると利用でき、上記の手順は一回のみ

実行します。

2. MCU → MCU PIC 16F84A U1 →デバッグ表示を選択します。

または

設計ツールボックスの MCU ワークスペースにある項目上の右クリッ

ク詳細メニューを使用します。
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デバッグ (「MCU の参照番号」)、この場合デバッグ (U1) という回

路図キャプチャワークスペースで別のタブが開きます。
 

デバッグ表示の上部にあるドロップダウンリストを使用して、Multisim
が内部生成する逆アセンブリ命令、およびアセンブラまたはコンパイラが

生成するリスティングファイルを選択します。リスティングファイルの形

式はコードのビルドに使用したツールによって異なります。

LCD の例では、コードはアセンブリで記述され、Microchip アセンブリ

ツールによってビルドされます。Microchip アセンブラは、各アセンブ

リ命令のすべての操作コードを含むリスティングファイル（.lst）を生

成します。デバッグリスティングビューは、このリスティングファイルか

らの情報を表示します。Multisim は、内部逆アセンブラを使用して逆ア

センブリフォーマットを生成し、操作コード命令をアセンブリ命令に逆ア

センブルします。

デバッグリスティングに必要な情報がすべて含まれているため、この

フォーマットはこの例では必要ありません。MCU プロジェクトがマシン

コード（.hex）ファイルのみをロードする場合、逆アセンブリ表示には

逆アセンブルされた操作コード命令が表示され、MCU で何が起こってい

るかを見ることができます。このような種類の MCU プロジェクトのリス

ティングファイルがないため、逆アセンブリ表示が役に立ちます。

1  ドロップダウンリスト  
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ブレークポイントを追加する 
シミュレーションの停止中および実行中に、ソースコードビューにブレー

クポイントを追加することができます。2 通りの方法でマイクロコント

ローラプロジェクトにブレークポイントを追加することができます。

1 つ目は、ソースコードビューで追加する方法です。この例では、回路図

キャプチャワークスペースの main.asmタブのみが利用可能なソース

コードビューです。

メモ MCU 設計に複数のファイルが含まれている場合は、各ソースコードファイルに

対してソースコードビューがあります。

また、デバッグ表示ウィンドウでブレークポイントを設定することもでき

ます。逆アセンブリ表示またはデバッグリスティングビューでブレークポ

イントを設定することができますが、この例ではデバッグリスティング

ビューのみを使用します。
 

ソースコードビューでブレークポイントを追加するには、以下の手順に従

います。

1. U1 のデバッグ表示を開きます。

2. 設計ツールボックスで main.asmをダブルクリックします。

3. STARTラベルのすぐ下にあるライン BCF STATUS, RP0までスクロー

ルします。

1  灰色の列  



第 4 章 Multisim MCU チュートリアル

© National Instruments Corporation 4-11 NI Circuit Design Suite スタートアップガイド

4. ライン BCF STATUS, RP0の隣の main.asmウィンドウの左側にある

1 番目の（灰色）列をダブルクリックします。そのラインにブレーク

ポイントが設定されたことを示す赤い丸が表示されます。

5. シミュレート→実行を選択します。シミュレーションは、設定したブ

レークポイントで自動的に一時停止します。デバッグ表示は、MCU
プログラムの実行が一時停止している場所を黄色の矢印で表示しま

す。 

以下の手順に従って、ブレークポイントを削除します。

1. デバッグ表示または main.asmソースコードビューでブレークポイ

ントをダブルクリックします。

または

MCU →すべてのブレークポイントを削除を選択して、すべてのブ

レークポイントを削除します。 

メモ デバッグ表示で、ソースコードビューと同じ方法でブレークポイントを追加ま

たは削除できます。

一時停止してステップ 
1. MCU →すべてのブレークポイントを削除を選択して、すべてのブ

レークポイントを削除します。

2. 回路設計表示（Getting Started MCU タブ）でシミュレート→実行

を選択します。「Graphical LCD T6963CC for Multisim」という文

字が LCD コンポーネントに表示され始めます。 

3. シミュレート→一時停止を選択します。 

4. U1 のデバッグ表示へ移動し、一番左側の列の黄色の矢印で示される、

MCU が実行を停止した場所にあるデバッグリスティングビューの

コードラインに注目します。
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5. MCU → MCU PIC16F84A U1 →メモリ表示を選択して、マイクロコ

ントローラ U1 の内部のメモリの現在の状態を表示します。IROM セ

クションのプログラムカウンタ PCの値が、黄色の矢印が示すライン

のアドレス値よりも 1 大きいことに注意します。上記の図の例では、

デバッグ表示のアドレスは 192 で、メモリ表示の PC 値は 193 です。

メモ シミュレーションを一時停止したときに MCU が現在のコマンドを完了してい

な場合は、プログラムカウンタ値はアドレス値と同じです。

メモリ表示の他のセクションで、マイクロコントローラのメモリの他

の部分の値を表示することができます。

6. シミュレーションツールバーの中に入るボタンをクリックします。 

7. 現在の命令が実行され、シミュレーションは次の命令で一時停止しま

す。

8. シミュレート→停止を選択します。 
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一時停止して外に出る 
1. MOVWF PORTBの SEND_DATAサブルーチンにブレークポイントを配

置します。

2. シミュレート→実行を選択します。シミュレーションがブレークポイ

ントで一時停止します。

3. シミュレーションツールバーの外に出るボタンをクリックして、

SEND_DATAサブルーチンの外に出ます。 

4. シミュレーションは、SEND_DATAサブルーチン内の残りのすべての

命令を実行し、SEND_DATAサブルーチンへの呼び出し後の最初の命

令で一時停止します。

一時停止して中に入る 
1. MCU →すべてのブレークポイントを削除を選択します。 

2. 黄色の矢印のすぐ上で外に出た場所、SEND_DATAへの呼び出しにブ

レークポイントを配置します。

3. シミュレート→実行を選択します。シミュレーションは配置したばか

りのブレークポイントで一時停止します。 

4. シミュレーションツールバーの中に入るボタンをクリックします。シ

ミュレーションが SEND_DATAサブルーチン内で一時停止します。 

一時停止して飛び越える 
1. シミュレート→実行を選択します。シミュレーションは、サブルーチ

ン SEND_DATAへの呼び出し時に、上記で設定したブレークポイント

と同じポイントで一時停止します。 

2. シミュレーションツールバーの飛び越えるボタンをクリックします。

SEND_DATAサブルーチン全体が実行され、シミュレーションは CALL 
SEND_DATA命令の次の命令で一時停止します。 

カーソルまで実行 
1. MCU →すべてのブレークポイントを削除を選択します。 

2. 再度 LCD にデータを送信するために SEND_DATAサブルーチンが呼

び出されるので、このサブルーチンの内側のラインをクリックしま

す。

3. シミュレーションツールバーのカーソルまで実行ボタンをクリックし

ます。シミュレーションは、SEND_DATAサブルーチン内でクリック

した命令に MCU が到達するまで実行されます。そして、一時停止

し、ラインの隣に黄色の矢印を配置します。 
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A
技術サポートおよびプロフェッ
ショナルサービス

技術サポートおよびその他のサービスについては、NI のウェブサイト

（ni.com/jp）の下記のセクションを参照してください。

• サポート — 技術サポート（ni.com/jp/support）には以下のリ

ソースがあります。

– セルフヘルプリソース — 質問に対する回答やソリューションが
必要な場合は、ナショナルインスツルメンツのウェブサイト

（ni.com/jp/support）でソフトウェアドライバとアップデー
ト、検索可能な技術サポートデータベース、製品マニュアル、
トラブルシューティングウィザード、種類豊富なサンプルプログ
ラム、チュートリアル、アプリケーションノート、計測器ドライ
バなどをご利用いただけます。 ユーザ登録されたお客様は、

NI ディスカッションフォーラム（ni.com/jp/dforum）にアク
セスすることもできます。  

– 標準サポート・保守プログラム（SSP）—NI のアプリケーション
エンジニアによる電話または E メールでの個別サポート、サー
ビスリソースセンターからのオンデマンドトレーニングモジュー
ルのダウンロードが可能となるプログラムです。 このプログラム
には製品ご購入時にご加入いただき、その後 1 年ごとに契約更
新してサービスを継続することができます。 
その他の技術サポートオプションについては、ni.com/jp/
servicesをご覧いただくか、ni.com/contactからお問い合
わせください。 

• トレーニングと認定 — 自習形式のコースキットやインストラクタに

よる実践コースなどのトレーニングおよび認定プログラムについて

は、ni.com/jp/trainingを参照してください。

• システムインテグレーション — 時間の制約がある場合や社内の技術

リソースが不足している場合、またはプロジェクトで簡単に解消しな

い問題がある場合などは、ナショナルインスツルメンツのアライアン

スパートナーによるサービスをご利用いただけます。 詳しくは、NI 営
業所にお電話いただくか、ni.com/jp/allianceをご覧ください。

NI のウェブサイト（ni.com/jp）を検索しても問題が解決しない場合は、

NI の国内営業所または米国本社までお問い合わせください。 海外支社の電

話番号は、このマニュアルの冒頭に記載されています。 また、NI ウェブサ

イトの Worldwide Offices セクション（ni.com/niglobal（英語））か

ら海外支社のウェブサイトにアクセスすることもできます。 各支社のサイ

トでは、お問い合わせ先、サポート電話番号、E メールアドレス、現行の

イベント等に関する最新情報を提供しています。



© National Instruments Corporation I-1 NI Circuit Design Suite スタートアップガイド

索引

数値
2 ピンコンポーネント

ワイヤに直接ドロップする、2-8

B
BOM、2-16

M
MCU チュートリアル、4-2
MCU チュートリアルの概要、4-1
MCU デバッグ機能、4-7
MCU デバッグの概要、4-7
Multisim チュートリアルの概要、2-3
Multisim にコンポーネントを配線する、2-9
Multisim にコンポーネントを配置する、2-5
Multisim ファイルを開く、2-4
Multisim ファイルを保存する、2-4

N
NI のサポートとサービス、A-1

U
Ultiboard DB 部品を配置する、3-10
Ultiboard からファイルをエクスポートする、

3-21
Ultiboard チュートリアルを開く、3-3
Ultiboard で部品を移動する、3-12
Ultiboard に部品を配置する、3-7、3-10
Ultiboard にトレースを配置する、3-13
Ultiboard の 3D 設計、3-21

あ
アセンブリプログラム、4-4
後処理、2-15

い
一時停止してステップ、4-11
一時停止して外に出る、4-13
一時停止して飛び越える、4-13

一時停止して中に入る、4-13
インタフェース

要素、2-1、3-1

う
ウェブリソース、A-1

か
カーソルまで実行、4-13
解析、2-13
回路図キャプチャ、2-4
仮想計測器、2-11

き
技術サポート、A-1
技術サポートデータベース、A-1

く
グラファ、2-15

け
計測器ドライバ（NI リソース）、A-1

こ
コメント、3-21

さ
材料表、2-16
サポート , 技術、A-1
サンプル（NI リソース）、A-1

し
自動経路設定、3-19
自動配置、3-18
シミュレーション、2-11
手動トレース、3-14
診断ツール（NI リソース）、A-1



索引

NI Circuit Design Suite スタートアップガイド I-2 ni.com/jp

せ
製造 / アセンブリ、3-20
製品、1-1
接続マシントレース、3-17

そ
ソフトウェア（NI リソース）、A-1

ち
チュートリアルの概要、1-1

と
ドキュメント

NI リソース、A-1
本書で使用する表記規則、v

ドキュメントで使用する表記規則、v
ドライバ（NI リソース）、A-1
トラブルシューティング（NI リソース）、A-1
トレーニングと認定（NI リソース）、A-1

な
ナショナルインスツルメンツのサポートと

サービス、A-1

ふ
部品をドラッグする、3-8、3-9
ブレークポイント、4-10
プログラミングサンプル（NI リソース）、A-1

へ
ヘルプ

技術サポート、A-1

ほ
ボードアウトライン、3-4
ボードのクリーンアップ、3-20

ゆ
ユーザインタフェース

要素、2-1
誘導型トレース、3-16

れ
レポート、2-16


	Getting Started with NI Circuit Design Suite
	Support
	Worldwide Technical Support and Product Information
	National Instruments Corporate Headquarters
	Worldwide Offices

	Important Information
	Warranty
	Copyright
	Trademarks
	Patents
	WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

	Conventions
	Contents
	Chapter 1 Introduction to NI Circuit Design Suite
	NI Circuit Design Suite Product Line
	The Tutorials

	Chapter 2 Multisim Tutorial
	Introduction to the Multisim Interface
	Overview
	Schematic Capture
	Opening and Saving the File
	Placing the Components
	Wiring the Circuit

	Simulation
	Virtual Instrumentation
	Analysis
	The Grapher
	The Postprocessor

	Reports
	Bill of Materials


	Chapter 3 Ultiboard Tutorial
	Introduction to the Ultiboard Interface
	Opening the Tutorial
	Creating a Board Outline
	Placing Parts
	Dragging Parts from Outside the Board Outline
	Dragging Parts from the Parts Tab
	Placing the Tutorial Parts
	Placing Parts from the Database
	Moving Parts

	Placing Traces
	Placing a Manual Trace
	Placing a Follow-me Trace
	Placing a Connection Machine Trace

	Auto Part Placement
	Autorouting Traces
	Preparing for Manufacturing/Assembly
	Cleaning up the Board
	Adding Comments
	Exporting a File

	Viewing Designs in 3D

	Chapter 4 Multisim MCU Tutorial
	Overview
	About the Tutorial
	Understanding the Assembly Program

	Working with the MCU Debugging Features
	Debug View Overview
	Adding a Breakpoint
	Break and Step
	Break and Step Out
	Break and Step Into
	Break and Step Over
	Run to Cursor


	Appendix A Technical Support and Professional Services
	Index
	Numerics
	A-M
	N-W


	Erste Schritte mit NI Circuit Design Suite
	Support
	Deutschsprachige Niederlassungen
	Lokaler technischer Support
	Technischer Support und Produktinformation weltweit
	National Instruments Corporate Firmenhauptsitz
	Internationale Niederlassungen

	Wichtige Informationen
	Garantie
	Urheberrechte
	Marken
	Patente
	WARNUNG ZUR NUTZUNG VON NATIONAL INSTRUMENTS PRODUKTEN

	Symbole und Darstellungen
	Inhaltsverzeichnis
	Kapitel 1 Einführung in die NI Circuit Design Suite
	NI Circuit Design Suite
	Einführungen

	Kapitel 2 Einführung in Multisim
	Multisim-Benutzeroberfläche
	Überblick
	Schaltplan
	Öffnen und Speichern der Datei
	Einfügen der Bauelemente
	Verbinden der Bauelemente

	Simulation
	Virtuelle Messinstrumente
	Analyse
	Graphanzeige
	Postprozessor

	Berichte
	Stückliste


	Kapitel 3 Einführung in Ultiboard
	Ultiboard-Benutzeroberfläche
	Öffnen der Einführung
	Auswahl des Leiterplattenumrisses
	Platzieren von Bauelementen
	Verschieben von Bauelementen in den belegbaren Leiterplattenbereich
	Ziehen von Bauelementen aus der Registerkarte “Bauelemente” in die Schaltung
	Einfügen der Bauelemente dieser Einführung
	Einfügen von Bauelementen aus der Datenbank
	Bauelemente verschieben

	Verlegen von Leiterbahnen
	Manuelles Verlegen von Leiterbahnen
	Verlegen von Follow-me-Leiterbahnen
	Vollautomatisches Verlegen von Leiterbahnen

	Automatische Bestückung
	Automatische Leiterbahnführung
	Vorbereitung für die Leiterplattenfertigung
	Aufräumen der Leiterplatte (Clean-Up)
	Hinzufügen von Kommentaren
	Exportieren von Dateien

	3D-Ansicht von Schaltungen

	Kapitel 4 Einführung in Multisim MCU
	Überblick
	Über diese Anleitung
	Funktionsweise des Assembler-Programms

	MCU-Fehlersuchfunktionen
	Übersicht zur Fehlersuche
	Einfügen von Haltepunkten
	Unterbrechen und in/aus Funktionen hinein-/herausspringen
	Unterbrechen und aus Funktion herausspringen
	Unterbrechen und in Funktion hineinspringen
	Unterbrechen und Funktionsaufruf überspringen
	Zum Cursor


	Anhang A Technische Unterstützung und professioneller Service
	Stichwortverzeichnis
	Zahlen
	A-K
	L-Z


	NI Circuit Design Suite スタートアップガイド
	サポート
	技術サポートのご案内
	日本ナショナルインスツルメンツ株式会社
	National Instruments Corporation
	海外オフィス

	必ずお読みください
	保証
	著作権
	商標
	特許
	National Instruments Corporation 製品を使用する際の警告

	表記規則
	目次
	第1章 NI Circuit Design Suite の概要
	NI Circuit Design Suite の製品ライン
	チュートリアル

	第 2章 Multisim チュートリアル
	Multisim インタフェースの概要
	概要
	回路図キャプチャ
	ファイルを開いて保存する
	コンポーネントを配置する
	回路を配線する

	シミュレーション
	仮想計測器
	解析
	グラファ
	後処理

	レポート
	材料表


	第 3章 Ultiboard チュートリアル
	Ultiboard インタフェースの概要
	チュートリアルを開く
	ボードアウトラインを作成する
	部品を配置する
	ボードアウトラインの外側から部品をドラッグする
	部品タブから部品をドラッグする
	チュートリアルの部品を配置する
	データベースから部品を配置する
	部品を移動する

	トレースを配置する
	手動トレースを配置する
	誘導型トレースを配置する
	接続マシントレースを配置する

	自動部品配置
	トレースを自動経路設定する
	製造/アセンブリの準備をする
	ボードをクリーンアップする
	コメントを追加する
	ファイルをエクスポートする

	設計を3Dで表示する

	第 4章 Multisim MCU チュートリアル
	概要
	チュートリアルについて
	アセンブリプログラムを理解する

	MCU デバッグ機能を使用する
	デバッグ表示の概要
	ブレークポイントを追加する
	一時停止してステップ
	一時停止して外に出る
	一時停止して中に入る
	一時停止して飛び越える
	カーソルまで実行


	付録 A 技術サポートおよびプロフェッ ショナルサービス
	索引
	数値
	B-U
	あ-し
	せ-れ





